iMovie imports - grey thumbnails, can't select

Discussion in 'Mac Apps and Mac App Store' started by, Nov 20, 2012.

  1. macrumors newbie

    Nov 20, 2012
    I'm running the latest iMovie purchased via the App Store. I've imported videos in the past from my gopro but I'm having a problem with an event. I have several vids to import as an event but two problems. The thumbnails take 3 hours to generate but then they're all grey anyway. Also about 50% of the videos I can make selections from. If I drag the into my project I get audio only. It i try to preview them in the event library it skips back to the first clip in the event.

    I've deleted my thumbnails and restarted twice. It rebuilds thumbnails but no change.

    Any ideas what the fix may be?
  2. thread starter macrumors newbie

    Nov 20, 2012
    I did some testing. It seems to be happening with my 720p videos from my GoPro.

    I also converted the videos to M4V but really no change. The thumbnails are better but still not working. I still get audio only from the clips if I select them.
  3. Dave Braine macrumors 68040

    Dave Braine

    Mar 19, 2008
    Warrington, UK
  4. thread starter macrumors newbie

    Nov 20, 2012
    I was able to get them to import by just moving the imported videos to their own imovie events with only a max of 6 videos in each event. Odd that simply moving the videos fixes the thumbnails and playback issues.
  5. Bkxmnr macrumors regular


    Feb 9, 2009
    Wichita, KS
    Try changing the extension from m4v to mp4. It has worked for me in the past. YMMV though.
  6. thread starter macrumors newbie

    Nov 20, 2012
    My issue was MP4s from my gopro not importing. I repackaged as M4V with no change in results.

Share This Page