iMovie isn't auto-detecting my camera anymore

douggorilla

macrumors newbie
Original poster
Dec 22, 2008
26
0
I've been using my Vixia HF200 HD camera for over a year, and for the same amount of time, I've been transferring the videos I recorded on it to my computer using iMovie. Unfortunately, for no apparent reason, iMovie isn't detecting my camera anymore. I have absolutely no idea what to do now. Could somebody please help me detect my camera again? Thanks!
 

Brian33

macrumors 6502a
Apr 30, 2008
814
66
USA (Virginia)
Perhaps this is too obvious, and I don't mean to offend, but is it either plugged in or have a fresh battery charge?

Maybe the camera "broke" -- can you try it on another Mac, or, try another camera on your Mac?

There is a button in iMovie that you can click on to bring up the camera control window, have you tried that? (I've never needed to use it, but it is there.)

That's the extent of my ideas, but someone else trying to help may wonder what version of iMovie you're using...
 

douggorilla

macrumors newbie
Original poster
Dec 22, 2008
26
0
The camera was fully charged, and I tried a different camera which worked fine in iMovie.

Where is the camera control window? Also, I'm using iMovie '08.
 

Brian33

macrumors 6502a
Apr 30, 2008
814
66
USA (Virginia)
I was mistaken, it's actually called the Camera Import Window. In iMovie 08 it's the button on the far left of the button bar/toolbar that's in the center of the window. The keyboard shortcut Command-I also brings up the window.

For me, the Camera Import Window will let me select (near the bottom) my attached miniDV camera or the built-in iSight camera for importing video events. I just thought possibly you could select your Vixia there, although I guess it won't show up if it's not being detected.

It's awful frustrating that it worked for a year and then stopped! I'm assuming you use FireWire to connect the Vixia camera; could the FireWire (or other) cable have gotten damaged somehow?
 

douggorilla

macrumors newbie
Original poster
Dec 22, 2008
26
0
The camera isn't showed up in the Camera Import Window. I tried two other FireWire cables, and still my video clips won't appear in iMovie.
 

Bamse6540

macrumors newbie
Aug 15, 2010
1
0
I have recently experienced the same problem. iMovie does not anymore automatically detect my camera (Sony HDR-CX505). The only option available when I push the camera button is iSight showing myself on the screen. (Pretty boring). The camcorder do appear in Finder. My solution is to restart the Mac and Eureka, it all works until next time. It should not be like this but I have not yet found a proper way to solve this problem.:confused:
 

Loa

macrumors 68000
May 5, 2003
1,599
46
Québec
Hello,

I don't know about the Sony, but my Canon (I'm the one who started the referenced thread above) is not recognized if I don't delete files that have already been uploaded.

It's a pain and should be really really easy to fix by Apple, but as it is, we're stuck with this bug. And it IS a bug.

Loa
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.