Imovie lost clips. any advice?

Discussion in 'Digital Video' started by luke10000, Jan 3, 2008.

  1. luke10000 macrumors newbie

    Joined:
    Jan 3, 2008
    #1
    this is the first time i have posted on a forum so apologies if something is wrong. so heres the problem:

    i was recording in Imovie HD when and had to shut down mid recording, the file was not sent to the Imovie trash but to the finders trash. so am left with a .mov file of the recording however:

    opening in vlc produces the error:
    mp4: MP4 plugin discarded (no moov box)

    dragging the clip back into imovie produces the error:
    "the file failed to be imported - quicktime could not parse the file - 2048"

    i tried using a program called file juicer which produced the movie clip in a 1000's of jpegs. so i know that there is the full content is still in the file. i hope there is a way of recovering this clip. its 3gb in size

    i also used file salvage to search for any lost clips but none were found

    i have checked in the media folder in the package contents in the projects but i did not find any files. i would like to get these corrupted imovie clip files to work some how if anyone could give me some advice it would be great

    thnks
     
  2. Texas04 macrumors 6502a

    Texas04

    Joined:
    Jul 2, 2005
    Location:
    Texas
    #2
    The problem is the fact that iMovie was not able to "complete" the file so that it can be rad by quicktime or other media players. Because you stopped mid recording it put in the frames, but did not bundle it all up and therefore it cant be played back. I don't know of any way to recover your data so you might be stuck doing it over again... :confused:
     
  3. ftaok macrumors 603

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #3
    Lemme get this straight ... you were recording via the iSight directly onto the hard drive? Otherwise, you could just reimport from the miniDV tape.

    Maybe you could try running the file that you extracted through MPEGStreamClip. You could convert the DV file into a separate DV file. Worth a shot.

    ft
     
  4. luke10000 thread starter macrumors newbie

    Joined:
    Jan 3, 2008
    #4
    thanks, could not open the open the file in MPEG streamclip. tried open anyway then after some processing error saying no video found. i know its there though! any more ideas would be great
     
  5. chmorley macrumors 6502a

    chmorley

    Joined:
    Jan 2, 2002
    Location:
    Denver, CO

Share This Page