iMovie will not open

Discussion in 'Mac Apps and Mac App Store' started by JoshLV, Aug 22, 2009.

  1. JoshLV macrumors regular

    Joined:
    Jan 16, 2008
    Location:
    Las Vegas
    #1
    I tried to transfer a clip from EyeTV to iMovie '08 and iMovie will no longer open. It tries to open but after about 10 seconds it closes and tells me to relaunch. I have quite a few clips in iMovie totalling about 1 hour in length. Could it be taking up too much space or something? How can I get iMovie to open? :confused:
     
  2. Gentile macrumors regular

    Gentile

    Joined:
    Apr 29, 2007
    Location:
    Ohio
    #2
    iMovie does not accept all types of video. Try exporting the clip from eyetv using the AppleTV preset and it should work.
     
  3. JoshLV thread starter macrumors regular

    Joined:
    Jan 16, 2008
    Location:
    Las Vegas
    #3
    They have had no problem until now. I was fine exporting them into iMovie, then into QuickTime, then onto YouTube. I didn't change anything but now it just won't open for some reason.
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    Poke around in ~/Movies/iMovie Events and see if a folder was created with a name similar to the file you had exported to iMovie. Drag it out to the Desktop, try launching iMovie again. iMovie may still be trying to import/load that incomplete file for some reason.
     
  5. JoshLV thread starter macrumors regular

    Joined:
    Jan 16, 2008
    Location:
    Las Vegas
    #5
    hmmmm no dice. I deleted the clip entirely yet it still won't open. :mad:
     
  6. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    Alright well if it's not due to the recently imported clip, to get a better idea of whether we might be barking up the wrong tree and if reinstalling iMovie may be the ultimate solution, create a test user account with administrator privileges, login to it, and try launching iMovie. If it launches ok, it's quite possibly something in your ~/Library folder, either in Caches or Preferences which could be causing the issue. If it doesn't launch in the other user either, reinstalling iMovie with install disc 2 or your iLife disc may be the fix.
     
  7. JoshLV thread starter macrumors regular

    Joined:
    Jan 16, 2008
    Location:
    Las Vegas
    #7
    I tried your suggestion and iMovie opened just fine in the Guest account.
     
  8. JoshLV thread starter macrumors regular

    Joined:
    Jan 16, 2008
    Location:
    Las Vegas
    #8
    Cleaned out a lot of my clips and still won't load. Am I going to have to reinstall?
     
  9. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
  10. JoshLV thread starter macrumors regular

    Joined:
    Jan 16, 2008
    Location:
    Las Vegas
    #10
    Damn. Ehhh stupid OT question: How do I reinstall iMovie?? =/
     
  11. JoshLV thread starter macrumors regular

    Joined:
    Jan 16, 2008
    Location:
    Las Vegas
    #11
    Still a problem. I don't have the iLife disc because it came with my MBP. How can I reinstall this?
     

Share This Page