iMovie won't launch. Have only used it once.

Discussion in 'Mac Basics and Help' started by permutated, May 28, 2008.

  1. permutated macrumors member

    Joined:
    Jan 23, 2008
    #1
    Specs: Macbook Pro, OSX 10.5, iLife 07'.

    So here's the deal. I did the disk repair last night because iMovie wouldn't load, it just bounces in the dock for +30 seconds, then stops, when I hold the icon down it says "application not responding".

    I repaired the disk and now I'm having the same problems. I tried just installing iLife from the OSX disk but it doesn't have an install for it. Is there a way I can reinstall OSX without deleting optionally installed programs like Logic and Reason, and without erasing things like pictures or documents?

    Is there something I can do other than taking it to an :apple: store? Does anyone know what's wrong or why it won't launch?
     
  2. sharky05 macrumors regular

    Joined:
    Dec 9, 2007
    #2
    If you've got Leopard, you should be able to install iMovie separately (once it's been removed). Just insert leopard disk 1 and open the 'install bundled software only' package. Once you get to the 'installation type' step of the installer, click the customise button at the bottom, and select iMovie.

    If the worst comes to the worst, you could also try the old iMovie, http://www.apple.com/support/downloads/imovieHD6.html which is freely downloadable for iLife 08 users
     
  3. robanga macrumors 68000

    robanga

    Joined:
    Aug 25, 2007
    Location:
    Oregon
    #3
    This was a similar issue that I just fixed that may help you. I found the answer on google. Basically iMovie was launching for me, but there was no main screens showing any projects or editing tools etc.

    The (rather strange) fix for this was to go into preferences for the display and calibrate it. That's it. One calibration and iMovie was back working normally.
     
  4. Latro macrumors member

    Joined:
    Mar 23, 2008
    #4
    the fix that robanga suggested worked for me.

    Additionally, I believe that apple has released an update to iMovie that may also fix the problem. So, try system updates also.
     
  5. r88my macrumors regular

    Joined:
    Oct 28, 2007
    Location:
    Manchester UK
    #5
    Make sure you have updated to the latest version. I had a similar problem but an update sorted it out.
     
  6. paulfriedman7 macrumors newbie

    Joined:
    Jul 24, 2008
    Location:
    Los Angeles
    #6
    iMovie won't launch

    Truly bizarre, but robanga's solution above worked for me. Imovie launched but wouldn't open a window and everything on the File menu except Import from Camera was grayed out.

    I opened System Preferences. Displays. Color. Calibrate. Went through the display calibration menus using the default settings. Afterwords iMovie worked perfectly.

    The iMovie tech at Apple was completely baffled and was going to have me completely reinstall my system before I stumbled on this fix.

    Computers can be VERY mysterious at times.
     

Share This Page