imovie won't let me slow clip

Discussion in 'Mac Basics and Help' started by annabelli137, Mar 30, 2007.

  1. annabelli137 macrumors newbie

    Mar 30, 2007
    I'm trying to slow a clip down in iMovie hd 6.0.3 but each time I press apply it shows the progression bar at the botton of the clip for a split second and then returns to what it was before (a normal clip). I tried other clips and it does the same. I also tried other effects and they all worked perfectly. Does anyone have any idea what's wrong or if I'm doing something wrong? Thanks!!
  2. djstarrock macrumors 6502a


    Nov 23, 2006
    UK, Scotland, Glasgow
  3. annabelli137 thread starter macrumors newbie

    Mar 30, 2007
    tried that

    I tried restarting several times to no avail...any other ideas?
  4. mcgonagle6 macrumors newbie

    Mar 31, 2007
    Me Too!!!

    I am having the EXACT same problem. Can anyone help?
    I've rebooted, I've restarted, I've duplicated the clip and played with the start-end points. I've pushed every dang button on here. all the other effects work exactly as advertised, but slo mo is a no go. anyone?

Share This Page