iMovie won't open

Discussion in 'Mac Apps and Mac App Store' started by gaylebee, Jan 27, 2008.

  1. gaylebee macrumors newbie

    Joined:
    Jan 27, 2008
    #1
    Have been using iMovie without any problems. Out of the blue when I tried to open a project the application refused to open. At first it just bounced once in the dock and now it comes up with the message ‘You cannot open the application “iMovie” because it may be damaged or incomplete’.

    I have an iBook G4 1.2 (1.33 GHz, 256 MB Built-in) operating Mac OS X Panther 10.3.9. My iMovie is 4.0.1.

    I moved my iMovie projects into an external harddrive freeing up 12.17GB on my Macintosh HD. I searched for imovie preferences in my user library, couldn’t find them so ran a preference check with preferential treatment, it said all was ok. Tried opening iMovie in another user account anyway, same prob. Repaired permissions in disk utility. Tried in safe boot mode. Cleaned system & user caches with 3rd part software. Don’t have the install CD/DVD to do repair disk with me so used fsck, said all was ok. All my other apps are working fine.

    All I can think to do is uninstall and reinstall iMovie but I don’t have the discs with me and will this solve the problem? Is there any way to do this without my install discs? In a bit of a pickle, hoping someone can help.
     
  2. KingYaba macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons

Share This Page