iMovie won't won't import my video clips! (.mov files)

Discussion in 'Mac Basics and Help' started by AgWebdog, Jul 15, 2009.

  1. AgWebdog macrumors newbie

    Joined:
    Jul 15, 2009
    #1
    Hi there. I'm using a rather old version of iMovie (iMovie 3, actually) and this old dinosaur is having trouble uploading some clips I took of my screen using the trial version of Screen Record 2. I used it once before (Same program, same file format and everything!) and it worked fine, but now all of the sudden it won't accept the files.

    An error Message pops up after spending however long it took to upload the file

    Error During Import
    The file could not be imported: (-47)

    I don't know what that means, but if anyone could clarify what's wrong I'd really appreciate it.

    The movie also works fine in Quicktime player. I just need to edit it. Thanks for the help guys!
     
  2. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #2
    Probably the old version of iMovie as opposed to the movie file. I forget the basic QuickTime features (I have Pro), but see if you can export the video/save as through QT, then try that in various formats (mpg) to see what your iMovie will like.

    Edit: Also, check out perian.org. It's a free app that allows QT and iMovie to view/open additional formats. I'm not sure of its support for older systems, but it is a great app and might help you.
     
  3. mountweary macrumors newbie

    Joined:
    Mar 26, 2013
    #3
    A solution

    I was suffering through this issue for ages until I happened upon an unlikely solution: try CHANGING THE FILE NAME. This might sound ridiculously simple, but it worked for me after I went through countless attempts at working around what seemed like an impossible situation.

    It turns out that the forward slashes (/) I had used to identify the .mov files I was trying to import was the problem all along. Nothing indicated this, which is why it took me forever to figure it out (no error message, except for a "-37" error that appeared when I tried to import the same files on my old mac, using an older version of iMovie).

    This was immensely frustrating but I'm glad it's finally resolved. Hopefully sharing my experience here will be of use to someone out there!
     

Share This Page