Importing CDs - no track or artist names

Discussion in 'Mac Apps and Mac App Store' started by gabriellefunk, Aug 4, 2015.

  1. gabriellefunk macrumors member

    Joined:
    Jun 10, 2015
    #1
    When I insert a CD on my administrator account on my MacBook, it asks me if I want to import it but it does not pull up the artist's name or track information. It lists it as "Audio CD" and the tracks are Track 01, Track 02, etc. I have moved the .com.apple.iTunes.plist file under ~/Library/Preferences to the trash and that didn't seem to fix anything.

    HOWEVER, the track and artist information does pull up under my Guest User. Is there a setting that I'm missing?
     
  2. Partron22 macrumors 68020

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #2
    Do you have "Automatically retrieve CD track names from Internet" checked in your iTunes Preferences: 'General' pane?
     
  3. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #3
    Yes, that was the first thing that I checked unfortunately.
     
  4. Partron22 macrumors 68020

    Partron22

    Joined:
    Apr 13, 2011
    Location:
    Yes
    #4
    Did you click the checkbox off then on again? Sometimes prefs lie to you, and ever since Mavericks, plists have been cached in memory, so trashing one just gets the copy in memory written to disk as a replacement.

    File Menu -> Library -> Get Album Artwork. You should not have to do this, and I've no idea of the current scope of that command, so a backup before trying might be worthwhile, but it might fix the problem for you.
     
  5. gabriellefunk thread starter macrumors member

    Joined:
    Jun 10, 2015
    #5
    Yes, I did that. I actually got it resolved though. I deleted all of the files that started with com.apple.iTunes, and you can find them under ~Library/Preferences. That solved my issue and I got to keep all of the data.

    I hope this helps someone else, thank you for your help Partron22!
     

Share This Page