Importing CD's to iTunes


macrumors 6502a
Original poster
Aug 30, 2004
Adelaide, Australia
I've had a problem with importing CD's. When I put in a CD, it never displays the song names. I originally thought that the CD was to old (Iron Maiden- Best of the Beast) but then I put in Metallica S&M and the song names still didnt show. I know that they did show on iTunes on Windows...

So anything I'm doing wrong?


macrumors G4
They should show. AFAIK, they both use the CDDB database.

Is it just that CD or all of them? You are definitely online while you doing it?

If commercial CDs do import without being recognised, it's worth knowing that you can highlight them, go to Advanced and click on Get Track Info (or something along those lines - at any point in the future when you have an internet connection and it will go and check the database then.


macrumors 68000
May 15, 2005
NG9, England
Yeah, most are online these days, but I always make a point of saying that to people. You might want to check your connection as well, (if you tried to get the tracks names in one session, switched off then switched back on for example). The only time I was unable to get the information was when my ntl connection had cut out, a simple power off/on and all was okay again.


macrumors P6
May 10, 2004
You can set in the preferences that iTunes connects to CDDB automatically when you insert a new CD.