"Importing photos" is ssllooww

Discussion in 'Mac Apps and Mac App Store' started by Killerbob, Nov 10, 2013.

  1. Killerbob macrumors 6502a

    Jan 25, 2008
    After updating to Mavericks, iTunes 11.1.3, and Aperture 3.5, I am finding my iPhone/iPad syncs incredible slow. Especially the "Importing photos" step takes forever.

    I have my photos on my NAS, organised in Aperture, and have always synced from there in iTunes. Aperture, and a few of my albums are selected, and the correct photos go onto the iPhones/iPads. So it works, but it can easily take 15 minutes, even when I haven't added any photos, and even if I have, the copying across only happens in a later step.

    My photos are organised in Aperture with reference, but Aperture is not any faster/slower than it has ever been.

    I can hear on the NAS (ticking/searching sound) that it is spending the time looking for something, but I have no clue what???
  2. Killerbob thread starter macrumors 6502a

    Jan 25, 2008
    I have now done all the library "fixing" you can do in Aperture, and it didn't do a damn thing to the syncing problem:(

    This is something which has only started happening following the latest upgrades. I have about 50K photos in the library, and I sync about 2K of these, but it never took minutes to sync, only if I added a lot of new photos. Now, even when I don't do anything, just sync, it can take 10 min. to sync my iPhone.

    I do not think it is Aperture though... I open and use Aperture at the usual speed, i.e. very quickly. My library is on an Accelsior drive, with the photos references from my NAS.
  3. aristobrat macrumors G5

    Oct 14, 2005
    Do you connect to your NAS via SMB? I think Mavericks switched to using SMB2. Maybe that runs a lot slower than SMB did on Mountain Lion?
  4. Killerbob thread starter macrumors 6502a

    Jan 25, 2008
    Actually I have always used AFP as that was fastest when I tested the various solutions...
  5. Killerbob thread starter macrumors 6502a

    Jan 25, 2008
    If I choose to "Rebuild Database" in Aperture, will that affect my Faces and Places already identified?

Share This Page