Importing Photoshop file into InDesign - bad quality?!

Discussion in 'Design and Graphics' started by jason.w, Jul 19, 2010.

  1. jason.w macrumors newbie

    Joined:
    Jul 19, 2010
    #1
    Hi, I have just designed a logo in Photoshop that comprises of text. However, when I drag it into InDesign the quality of the text is awful (edges are fuzzy, etc.). Is there any way I can get a decent quality text from Photoshop?

    Thanks in advance
     
  2. heehee macrumors 68020

    heehee

    Joined:
    Jul 31, 2006
    Location:
    Same country as Santa Claus
    #2
    Could be 2 things.

    1. make sure your photoshop file is set to 300 dpi and that's when you start working on the file, not after.

    2. If it's set to 300 dpi, could be just a display performance setting. Object > Display Performance > High Quality Dispaly
     
  3. jason.w thread starter macrumors newbie

    Joined:
    Jul 19, 2010
    #3
    Thanks for the reply, I think it was already set to 300dpi as a default and when i put it to high performance, there was an improvement. It still didn't look as good as the text in InDesign... I remember reading somewhere that text in Photoshop is always bad quality when exported.. is there any truth in that?
     
  4. panoz7 macrumors 6502a

    panoz7

    Joined:
    Nov 21, 2005
    Location:
    Raleigh, NC
    #4
    Try exporting it and see if the quality improves. Even the high quality display in indesign isn't full quality.

    EDIT: Also, is there a reason that you're exporting rastor text from photoshop instead of generating it within indesign or illustrator?
     
  5. bigus7674 macrumors member

    Joined:
    Jan 4, 2005
    #5
    Photoshop in InDesign

    If you are working with a .psd format file, I would leave the text as vector in the Photoshop file (don't rasterize the text) and then bring that file into InDesign.

    Also, keep in mind that sometimes InDesign previews on the screen aren't as good as printouts so I would still do a printout, hopefully on a color or black and white laser printer, for a better representation of what it will print like.
     
  6. Poisonberry macrumors newbie

    Poisonberry

    Joined:
    Jul 19, 2010
    #6
    Photoshop text

    If you have checked your dpi, and made sure that your image is a not a giff or bitmap (also check that your bit depth is just 8-bit .. 16-bit dont always print),
    and are still hellbent on using the fonts from photoshop (not best adviced really) they change the text to a "shape-layer"
    CS4/CS5: rightclick on the text layers > in the popup panel choose "shape-layer"
    Or Layer > Type > Convert to Shape.

    And then save it as an .eps, or .psd or .tiff file.

    Good luck
     
  7. Jim Campbell macrumors 6502a

    Jim Campbell

    Joined:
    Dec 6, 2006
    Location:
    A World of my Own; UK
    #7
    This gets to the nub of the matter, TBH.

    Cheers!

    Jim
     
  8. snickelfritz macrumors 65816

    snickelfritz

    Joined:
    Oct 24, 2003
    Location:
    Tucson AZ
    #8
    InDesign: View > Display Performance > High Quality Display
    Also, try exporting the document to PDF, then view and/or print it in Acrobat to see if the quality of the text is actually an issue.

    I occasionally use bitmap text in print documents, and the printing quality is virtually indistinguishable from vector text, except at small sizes.
    Always use a vector format if possible though.
     
  9. eponym macrumors 6502

    Joined:
    Jul 2, 2010
    #9
    InDesign is simply showing a preview image. It's not going to flatten a high res PSD on the fly for layout purposes. It would slow down the app too much.

    You need to print it out or export to high quality PDF if you want to see the real deal.

    Also, if you're zooming in, you'll _never_ see it as crisp as the native vector-based text. The app is simply re-drawing the vectors to match your zoom level. It will be as crisp as your display allows. And when you print that text, it will be as crisp as the printer allows.
     
  10. voyou macrumors newbie

    Joined:
    Jul 7, 2012
    #10
    Hi everybody,

    Searching in Google I arrived at this thread. After finding the solution for my problem I'd like to post it here so people who encounter the same problem may have their solution as well.

    In my case, I imported an image from Photoshop, but it just wouldn't show in good quality in Indesign. The problem was that I had changed the file in Photoshop so Indesign showed an error message "broken link".

    To fix it I had to go to "Links" (Window->Links), rightclick my .psd file, and click "update link". Now the quality was fine.

    Hope this helps people who find themselves in the same situation as me.

    Regards
    Alex
     
  11. PrePressAcrobat macrumors member

    Joined:
    Nov 2, 2010
    #11
    Here is how it works:

    - With a .psd file - text and vector art IS RASTERIZED upon placement into InDesign.
    There is nothing you can do about that.

    - Photoshop .eps files will hold text and vectors going into InDesign
    and when exported or printed
    but
    the file IS RASTERIZED when re-opened in Photoshop.
    There is nothing you can do about that.

    - Photoshop PDF files retain text and vectors when placed into InDesign and when exported or printed from InDesign (or Photoshop).
    - Photoshop PDF files CAN be re-opened in Photoshop and retain their vectors and layers.
    - Layers can be turned on and off during placement into InDesign.
    - The file extension for a Photoshop PDF is actually .pdp
    if you change the extension to this in your file list - the file will open in Photoshop rather than Acrobat when double clicked. Also, with the .pdp extension the file will open with Photoshop when doing an "Edit Original"
    from inside of InDesign or Acrobat (rather than opening with Acrobat).

    - You CAN NOT use "Faux Bold" or Faux Italic" on type inside Photoshop
    when saving as Photoshop PDF - the text block will be rasterized.
    You MUST use the "real" font.

    - Save the file as a Photoshop PDF using the "Press Quality" preset.

    MSD
     
  12. PrePressAcrobat macrumors member

    Joined:
    Nov 2, 2010
    #12
    PS

    Do not ever use .eps files
    -
    unless you know that your printer is using low budget or archaic workflows.
    or
    Your printer specifically tells you to.
    (Many Sign shops still have older RIPs that have trouble with transparency)

    MSD
     
  13. Wouterrrr macrumors newbie

    Wouterrrr

    Joined:
    Jan 5, 2017
    #13
    --- Post Merged, Jan 5, 2017 ---
    Thank you So much! This solved my problem exactly and I can now go to sleep with no stress! :)
     
  14. dwig macrumors 6502

    Joined:
    Jan 4, 2015
    Location:
    Key West FL
    #14
    all good points, plus...

    ...
    - if using PDF, be sure that the export settings are set appropiately to avoid rasterizing the text and to avoid compressing the image, especially avoid using JPEG compression.
    - build the file in Ps to the EXACT size (inches or cm) needed in InDesign and build it at 300ppi. DO NOT scale the image in Id.
     
  15. macuser453787, Feb 9, 2017
    Last edited: Feb 9, 2017

    macuser453787 macrumors 6502

    Joined:
    May 19, 2012
    Location:
    Galatians 3:13-14
    #15
    I just tested this out of curiosity, and sure enough, it does. :)
    (Edit: Actually I now remember having seen this before. I just don't work with Photoshop EPS files that much these days.)

    One caveat though: The "Include vector data" option must be chosen in the EPS options window. If it's not, the text displays as raster when placed into InDesign.

    This setting is fine for many uses I'm sure. However here is a fair warning for anyone interested to know: The Press Quality setting uses JPEG compression, which is lossy and can create compression artifacts, which may or may not affect overall print quality.

    To eliminate this possibility, you can either turn off compression (which will result in a much, much larger PDF file size on disk), or you can use ZIP compression which is lossless, thus avoiding any compression artifacts. The ZIP option will also create a larger PDF file than the Press Quality setting, but not as large as a non-compressed PDF.
    --- Post Merged, Feb 9, 2017 ---
    Resolution (dpi) depends on the line screen (lpi) of the printing device.

    The traditional approach says that dpi should always be twice the lpi, so if the printing device uses 300 lpi, then the resolution should be 600 dpi. Or if 150 lpi, then 300 dpi, and so on.

    Although this is a good guideline, I've seen that it isn't necessarily a hard and fast rule. At my workplace, we print at 250 lpi but our official minimum dpi is less than that. :)
     
  16. dwig macrumors 6502

    Joined:
    Jan 4, 2015
    Location:
    Key West FL
    #16
    True, and it also depends on the screening technique. Stochastic screening has different "demands" than those of elliptical dot screening.

    This formula works quite well for elliptical dot screening, though 2x puts you a little on the high side of the optimal range. Higher than 2.5-3x and lower than 1.5x will both result in lower image quality.

    Another factor to consider is the printer/publisher. Some require 300ppi for all use, primarily for bureaucratic reasons.
     
  17. mostafa.kamel.me30 macrumors newbie

    mostafa.kamel.me30

    Joined:
    Feb 19, 2017
    #17
    Interesting and impressive article. Thanks to you for sharing such a nice article. I got some printing done from Graphic design couple of months back and I am happy with their service.
    The Printing Life
     

Share This Page