Impossible to Eject

Discussion in 'iMac' started by rabbitmonkey, Jul 12, 2007.

  1. rabbitmonkey macrumors newbie

    Joined:
    Jul 12, 2007
    #1
    I've got this slight problem. I've got a disc stuck in my stupid slot drive and I can't get it out. I've tried holding down the mouse button, holding E, Command+E, Apple+E, Command+., and all of the different possible button combos that had "eject" in the description that I could find. There is no OS on the thing, but I can open up OpenFirmware. I get
    Code:
    Apple PowerMac2,1 1.2f2 BootROM built on 09/09/99 at 18:58:29
    [...]
     ok
    0 > eject cd method <eject> not found; ihandle=ff9d2300 phandle=ff84de80 EJECT method failed
     ok
    1 >
    This poses a problem, because I can't eject (still). The drive is slot and thus has no magic eject button. I got this thing secondhand (read: crappy, free G3 or something) from my school a few years back. I doubt it has a warranty, and I really don't feel like paying for any part of this compter at all. Any ideas?

    [edit]
    When I boot normally I get the gray screen with the little question mark foldery icon, and that's all. If I hold alt/option I get blue screen with the same folder icon, as well as 2 buttons, one a circular arrow and the other a strait arrow. The CD still spins on boot (and really all the time).

    *bump*
    It'd be really great if anyone could help...
     
  2. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #2
    Smells like busted hardware, it seems that the CD drive is getting power but the Mac doesn't see it. Could be an undone cable, could be something more sinister.
     
  3. rabbitmonkey thread starter macrumors newbie

    Joined:
    Jul 12, 2007
    #3
    Weird, it was reading the first CD just fine..bah. I tried opening it but I had no luck, is there a doc somewhere on how to crack this thing open?
     
  4. carpeagnus macrumors newbie

    Joined:
    Jul 14, 2007
    Location:
    Louisville, KY
    #4
    It's a new safety thing

    Don't trade in or break your hardware. This had me frustrated for a while. I wish Apple would have announced this change more loudly, rather than letting us get all worked up, but alas. It's a new safety feature with OS X 10.4.10. You now have to hold down the eject button for two to three seconds for it to work. This is to prevent an accidental eject when your finger happens to slip onto this key.
     
  5. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #5
    there is a Macworld guide that might help out. This Google search should turn up others, perhaps even better ones.

    Remember that CRT monitors pack a hell of a wallop, even with the power disconnected. Don't mess with the tube. If you're lucky, all you'll have to do is clean out the dust bunnies, perhaps coax the disc out of the existing drive, touch everything up and be good to go.
     
  6. rabbitmonkey thread starter macrumors newbie

    Joined:
    Jul 12, 2007
    #6
    1. It was an old POS with Mac OS 8.6 before I >>ERASED THE HARD DRIVE<<
    B. I have no eject button
     

Share This Page