Impossible to update/restore iPhone

Discussion in 'iPhone Tips, Help and Troubleshooting' started by spalex, Oct 22, 2011.

  1. spalex macrumors newbie

    Joined:
    Oct 21, 2011
    #1
    I have a iPhone 3GS 16GB and it is in recovery mode.

    I am trying to restore and update the iPhone so it is back to factory settings however I always seem to get the message "The iPhone 'iPhone' could not be restored. An unknown error occured (1)"

    How can I get around this?

    Thanks
     
  2. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #2
    Via Google: http://theiphonewiki.com/wiki/index.php?title=ITunes_Errors#Below_100


    Since Apple is no longer signing iOS 4.3.5 and iOS5 requires iTunes 10.5 to be installed, I imagine you'd get an error if you're on an earlier version of iTunes and try to restore an iPhone at this point.

    What version of iTunes are you on? If you upgrade to 10.5 do you get the same error?
     
  3. spalex thread starter macrumors newbie

    Joined:
    Oct 21, 2011
    #3
    I am on iTunes 10.5 :(
     
  4. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #4
    Downgrade to 4.1 and you are fine. For some reason, Apple still sign this firmware.
     
  5. spalex thread starter macrumors newbie

    Joined:
    Oct 21, 2011
    #5
    Downgrade my iPhone firmware to 4.1?
     
  6. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #6
    Yes, or just put it into DFU mode and restore to OS5.
     
  7. spalex thread starter macrumors newbie

    Joined:
    Oct 21, 2011
    #7
    Wont I have problems downgrading my iPhone?

    I have put it into DFU mode already and this still shows the same error.

    I have also used sn0wbreeze to install a custom firmware which will work however the phone will constantly reboot itself over and over again and there is no wifi, bluetooth or signal.

    All I want to do is do an itunes restore but I am hit with this stupid error all the time
     
  8. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #8
    First, what is the reason you use sn0wbreeze to customs made the firmware for your phone? What are you trying to do here?

    Second, you still can downgrade your 3GS to 4.1. At the end of the process, you will get 1015 error, use TU to kick it out of recovery and your phone will have 4.1 firmware.
     
  9. spalex thread starter macrumors newbie

    Joined:
    Oct 21, 2011
    #9
    Heres what has happend, I have bought the iPhone off eBay that was advertised as being in recovery. So once arrived I tried to update it to the current version and got the error. I saw a post that you could get passed the iTunes errors by using a custom firmware which I did and it did work for ios 5 however it kept rebooting itself in an endless loop and when I did manage to get into the home screen there was no bluetooth, wifi nor signal service.

    I tried what you said about firmware 4.1 which did seem to work but a different error came up to what you said and other problems however I went to the apple store so I did not have time to post back to you.

    Apple told me that it was a firmware/hardware problem and it would have to be replaced?

    Anyway I am loading 4.1 back on again and I will post the error message.

    Thanks for your help BTW
     
  10. spalex thread starter macrumors newbie

    Joined:
    Oct 21, 2011
    #10
    Ok I have the error: 1002#

    Booted out of recovery by TU, iTunes takes an age to find the iPhone, then it will say "restore needed - iphone cannot make or recieve calls".

    Now it seems to be rebooting again.
     
  11. spalex thread starter macrumors newbie

    Joined:
    Oct 21, 2011
    #11
    I have it working now however it will continue to reboot itself. Also the wifi and bluetooth are greyed out and I have no service
     
  12. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #12
    You restored it with customs firmware. Didn't you?

    restore it with stock firmware and this issue will go away.
     
  13. spalex thread starter macrumors newbie

    Joined:
    Oct 21, 2011
    #13
    I restored it via redsn0w to unlock the phone, however when I try to restore the stock firmware I get an error (11). Is this phone bricked?
     
  14. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #14
    Which stock firmware are you trying to restore it to? did you put it into DFU mode first?
     
  15. spalex thread starter macrumors newbie

    Joined:
    Oct 21, 2011
    #15
    Yes, its 4.1 like you said
     

Share This Page