Impossible words to type on the iPhone

Discussion in 'iPhone' started by magicandmystery, Jan 1, 2009.

  1. magicandmystery macrumors member

    Joined:
    Jun 27, 2007
    #1
    Before I begin, I've found a workaround. But it's still pretty darn crazy.

    My gf bought a new car yesterday. I tried texting my friend what she bought, and what she was looking at. Turns out, you can't type those words. I've had a long, idiotic discussion with the knuckleheads on the Apple discussion boards. Blind devotion to any company is silly. But I digress...

    Try typing "Lexus", or "Acura" without pressing the little x to correct the iPhone. Can't do it, can you? It corrects the words to "Lexis", and "Acuta". Here's the fun part: The phone won't actually let you type "Lexus" or "Acura", even if you try skimming the keyboard to input the letters.

    You can type the "Lex" very easily- but the phone is incapable of letting you type the "u". Fun for the whole family! Hold down a letter directly after typing the "x" in "Lexus", (don't press the little x if it comes up). Try forcing the keyboard to recognize the "u". Crazy, huh? It will let you scrub over every letter EXCEPT the "u". Conversely, you can do the same thing with "Acura", and it won't let you type the "r".

    Yes, you can press the x to correct, and then type. But that's not the point. A slow and deliberate tap on the keyboard on the intended letter, should let you type that letter. But the iPhone doesn't, obviously, in every instance. And yes, you can turn off auto-correction entirely, but that kinda sucks to have to do. If anyone's interested, there IS a workaround. But you would think that you shouldn't have to, wouldn't you?
     
  2. Poat84 macrumors 6502

    Poat84

    Joined:
    Nov 21, 2008
    #2
    When u text, slide your finger over the letter and it will show you what letter you'll push.

    If your fingers are to big...might think about getting a stylus.
     
  3. KrazyKuul macrumors regular

    Joined:
    Nov 16, 2008
    #3
    autocorrect "keys" are very annoying at times.

    at one time, i had to email microsoft a bunch of times about windows xp, and it kept correcting "xp" to "so" after i typed and usually it will add a word to dictionary if you delete and perfectly type the word, but it will never add xp to dictionary.

    This may just be accidental for Honda motors, but I am sure apple did this to Windows since they hate them so much
     
  4. NDimichino macrumors 6502a

    NDimichino

    Joined:
    Jan 14, 2008
    Location:
    New Jersey
    #4
    It's because the phone predicts what you want to type, so it changes the keyboard accordingly.

    For example, since "Lexus" isn't really a word, the phone assumes you're going to type lexis. It makes the "o" and "u" non-existent, so if you accidentally hit them, you'll still get the "i," like it thinks you want.

    Try to type lexo. You can't. The "o" and "u" essentially turn into one giant "i" button.

    Annoying? Yeah, for some words. But it works so well most of the time it allows you to type accurately when you're probably not even close.
     
  5. nickspohn macrumors 68040

    nickspohn

    Joined:
    Jun 9, 2007
    #5
    It's been like this since Steve introduced the iPhone 2 years ago.
     
  6. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #6
    How exactly are big fingers related to auto-"correct" messing things up?
     
  7. KrazyKuul macrumors regular

    Joined:
    Nov 16, 2008
    #7
    he didnt quite understand the question/comment/statement
     
  8. magicandmystery thread starter macrumors member

    Joined:
    Jun 27, 2007
    #8
    Hi. I'm the original post. Please re-read me.
     
  9. magicandmystery thread starter macrumors member

    Joined:
    Jun 27, 2007
    #9
    Yeah. Unfortunately, the iPhone should be smart enough to recognize deliberate button presses. In its current incarnation, the iPhone software will not let you type the word Lexus or Acura (and I'm sure, a host of other words) without manually correcting the word by pressing the little x. Since that is the case, it can't even learn the word, because the iPhone can only learn words that are entered that can actually BE entered on the phone. I love my phone- even spent a silly amount to import an unlocked 3G one about 4 months ago, but some of the issues are starting to become glaring issues.
     
  10. Ninja Dom macrumors 6502

    Ninja Dom

    Joined:
    Feb 12, 2007
    #10
    The same happens with the word "unlock". It comes out as "unlick" before being auto corrected.
     
  11. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #11
    Settings > General > Keyboard > Auto-Correction: Off.
     
  12. aridon macrumors member

    Joined:
    Dec 10, 2007
    #12
    How about they actually fix the problem and allow us to add words to the list like every other spell check that had existed over the past ten years.
     
  13. magicandmystery thread starter macrumors member

    Joined:
    Jun 27, 2007
    #13
    That one doesn't happen to me at all. What software version are you running?
     
  14. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #14
    Woa.

    That is very irritating! I didn't realise that it changed it automatically for Lexus and Unlock.

    Usually, for typing gooble-de-gook, it'll show the word so when you hit space, it replaces it.
     
  15. magicandmystery thread starter macrumors member

    Joined:
    Jun 27, 2007
    #15
    Right? It's one of Apple's moves that's dumbfounding. Put that on the list with copy & paste (although I've only truly had the need once or twice), MMS, message forwarding, video camera, wireless music syncing, and (my personal favorite) music fading in/out to the next song.

    But... on to the workaround. Do the Settings->General->Keyboard->Auto-Correction->Off thing, and type in the word ("Lexus") 3 or 4 times, and then turn auto-correction back on. You still can't deliberately type "Lexus"- it will still type "Lexis", but it will suggest that you actually meant "Lexus". In essence, you've added it to the dictionary, albeit in a silly, asinine way.
     
  16. Me1000 macrumors 68000

    Me1000

    Joined:
    Jul 15, 2006
    #16
    If you hit the x enough, eventually the phone will remember it. if all else fails just add a folder in your contacts for words, and make each work a contact.
     
  17. clydefr0g macrumors newbie

    Joined:
    Jan 1, 2009
    #17
    if it's anything like the ipod touch, you can go to settings-general-keyboard, here you can turn "auto-corrections" off.
     
  18. Daremo macrumors 68000

    Daremo

    Joined:
    Jul 3, 2007
    Location:
    Chicago
    #18
    Another workaround for ANY word you type often, is to set up an address book entry into the list, and in the name column, add in the words you use. It will then accept those words when you type them.
     
  19. Rob Mclovin macrumors 6502

    Joined:
    Jul 24, 2008
    #19
    Ya its like that for words like Goose, Delorean, noob, etc.
     
  20. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #20
    How about typing the word "good" without accidentally typing "food"
     
  21. Doju macrumors 68000

    Joined:
    Jun 16, 2008
  22. poolish macrumors regular

    Joined:
    Jul 23, 2007
    Location:
    south coast, uk
    #22
    easy.
     
  23. Hutch1 macrumors 6502a

    Hutch1

    Joined:
    Jul 24, 2008
    Location:
    Guelph, ON
    #23
    When typing lexus just type l e x hold your finger on the u (you'll get u's plus all with accents) take your finger off then s. Lexus no problem, Another thing you can do is open a new note and if its a word you use often type it multiple times and it will add it to you dictionary.
     
  24. Hutch1 macrumors 6502a

    Hutch1

    Joined:
    Jul 24, 2008
    Location:
    Guelph, ON
    #24
    That one is no problem at all.
     
  25. Hutch1 macrumors 6502a

    Hutch1

    Joined:
    Jul 24, 2008
    Location:
    Guelph, ON
    #25
    That one is a problem cant do it without deleting the n "noon" and then putting the b in. Work around "newbie":D
     

Share This Page