Improper Eject Now Won't Detect HD

Discussion in 'Mac Basics and Help' started by cscswimmer227, Aug 26, 2010.

  1. cscswimmer227 macrumors newbie

    Joined:
    Aug 26, 2010
    #1
    I was copying files to my external hard drive (firewire) and finder froze and relaunched. I got the generic error saying that my "device was ejected improperly". Now when I try plugging in my hard drive my Macbook Pro (2008) it won't recognize it. I've tried:

    1. Using USB instead of Firewire
    2. Checking Disk Utility
    3. Checking System Profiler
    4. Resetting PRAM
    5. Resetting SMC
    6. Using Data Rescue 3

    Nothing seems to detect my hard drive.

    Any ideas or suggestions?
     
  2. patrick0brien macrumors 68040

    patrick0brien

    Joined:
    Oct 24, 2002
    Location:
    The West Loop
    #2
    Hmm. My guess is the drive kacked. That led to the freeze and subsequent inability to mount.

    What sort of sound does it make when plugged in?
     
  3. cscswimmer227 thread starter macrumors newbie

    Joined:
    Aug 26, 2010
    #3
    It goes through the normal sounds of the hard drive warming up and the spindle moving.

    I was having trouble with the drive before. It was one of the 1TB Seagate Barracuda's that had to be recalled about a year and a half ago.
     
  4. bepop123 macrumors newbie

    Joined:
    Sep 6, 2009
    #4
    G4 desktop spits out CD and can't see it on desktop

    I am not sure if something went wrong, when I tried to clean out all my files. Haven't used it for awhile. Could it be the battery? Have a new one, but have not installed it yet, put off opening the G4. Tried to reinitialize the HD, with the original disk, but it spit it out, and the blank disk the same. I have Tiger in there. It is with classic 9.5. I PRAMed it couple of times. Nothing helped. Used diskaid to straighten out the permissions. Anyone have any suggestions.

    I don't know how to do a new post there is only a button for replies, mine is a new question.....;O}
     

Share This Page