in Mac Terminal I receive: '{PATH}:/tools': not valid identifier

Discussion in 'Mac Pro' started by ilivenicely, Apr 21, 2017.

  1. ilivenicely macrumors newbie

    ilivenicely

    Joined:
    Apr 20, 2017
    Location:
    Beijing, China
    #1
    Today I tried to run an ifconfig in my terminal and encountered this problem :

    Last login: Fri Apr 21 14:10:52 on ttys000
    -bash: export: `{PATH}:/tools': not a valid identifier
    -bash: touch: command not found
    bogon:~ robertmccormick$ ifconfig
    -bash: ifconfig: command not found
    I've tried https://forums.macrumors.com/threads/bash-command-not-found-for-almost-anything.1072580/ and https://forums.macrumors.com/threads/help-terminal-wont-run-jar-file.1067170/

    when I entered :

    /bin/cat ~/.bashrc
    I get

    export PATH="$PATH:/Applications/DevDesktop/drush"
     
  2. Draeconis macrumors 6502a

    Joined:
    May 6, 2008
    #2
    Not really the right place to post this, but it sounds like you might want to look at your user account.

    Try running echo $HOME.
     
  3. tomvos macrumors 6502

    tomvos

    Joined:
    Jul 7, 2005
    Location:
    In the Nexus.
    #3
    Bash looks at more than one startup file. Depending on whether you start your bash interactive or non-interactive the relevant startup files change. So, it might be a good idea to check

    /etc/profile
    ~/.bash_profile
    ~/.bash_login
    ~/.profile

    as well as

    /etc/bashrc
    ~/.bashrc

    Perhaps one of these files will lead to the corrupt EXPORT command. Good luck.
     

Share This Page