(In XP) - Keyboard Issues, Wifi Dropping

Discussion in 'Mac Basics and Help' started by dark2light2, May 26, 2008.

  1. dark2light2 macrumors newbie

    Joined:
    May 26, 2008
    #1
    Hey guys, I recently purchased the newest MBP with the LED screen yada yada yada.

    Everything is quite amazing in the OSX side of things, however I had to install XP SP2 via bootcamp so that I could play Age of Conan.


    When doing that, I installed the drivers off the CD and everything seemed to be working fine... that is until I started to play Age of Conan.

    Randomly my keyboard will go insane, and if I press say.. s it will launch search. If I press e it will load My Computer. Random **** like that, pretty much like its trying to go to shortcuts instead of the real key.

    I am also trying to figure out whats the issue with my wifi.

    I use a WRT54G and I never get dropped or anything in OSX however in XP I get a super high latency and then disconnected from my wireless. It doesn't make any sense. It's the driver of the Apple provided CD.


    Please someone suggest guidance, i'm going insane searching google for these two problems..
     
  2. chscag macrumors 65816

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    If the MBP keyboard is only doing that while you're playing "Conan", then it might be the game itself that's re-mapping the keys. Does the keyboard act that way when you're not playing the game in Win XP?

    As for your Wi-Fi issue, have you run the wireless connection wizard to see if everything is setup OK? As for the drivers Apple supplies on the Leopard DVD, they may not be the latest and the greatest. What you can do is go to the hardware maker's web site and download the latest driver they have for Win XP. I had to do that with my graphics (MacBook, not Pro) chip. After I downloaded and installed the latest driver set from Intel, graphics display worked fine for my external monitor.

    Regards.
     
  3. operator207 macrumors 6502

    Joined:
    Jul 24, 2007
    #3
    Check for "sticky keys" in XP. I hate that crap.

    Basically it "sticks" shift or control or alt for you.
    Its in Control Panel under Accessibility Options.

    I would get a popup about this when playing NFS because of how I set it up. If you do not pay close attention to the popup, which interrupts your game, you turn them on.
     

Share This Page