InCase Slider / Power Support Anti-Glare Film Question

Discussion in 'iPhone Accessories' started by Eddie L., May 7, 2008.

  1. Eddie L. macrumors newbie

    Joined:
    May 7, 2008
    #1
    Hello all. I ordered a new InCase Slider case for my wife's iPhone this week, and I also bought the Power Support Anti-Glare film for the face of the iPhone. I love the look of the Slider case, and I think it is going to work great. However, we tried to put one of the Anti-Glare films on the face of the iPhone and we keep having the same problem when we try to put the Slider case back on. Every time that we try to slide/snap the bottom of the case back on, it pushes the Anti-Glare film slightly and causes bubbles under the film at the bottom of the iPhone. Has anyone else had this problem and is there an easy fix for it? Thanks in advance!!
     
  2. Jonathan_W macrumors member

    Joined:
    Jan 13, 2008
    Location:
    Newcastle, UK
    #2
    I have the same case as you except my screen protector is the crystal film version instead of the anti-glare version and the combination fits perfect on my iPhone :eek:

    Have you tried applying the film evenly?

    If the film is not applied evenly then you are likely to get the case to push the film a bit. It took me a couple of tries to apply the film evenly and I even messed up the one films during the process :eek:
     
  3. alansmallen macrumors 6502a

    Joined:
    Jun 25, 2007
    #3
    From experience, put the film on and use the iPhone naked for about a day. This will allow the film to "settle". Then apply the case.
     
  4. Eddie L. thread starter macrumors newbie

    Joined:
    May 7, 2008
    #4
    Thanks for the replies guys! I think that the film has been applied evenly, so I'll try using the iPhone without the case for a day or two to see if that lets the film "settle". Hopefully that will work. I'll post an update in a few days.
     

Share This Page