Incipio Feather- still a problem with the flash?

Discussion in 'iPhone Accessories' started by self, Nov 14, 2011.

  1. self macrumors regular

    Joined:
    Jul 11, 2008
    #1
  2. solo118 macrumors 65816

    Joined:
    May 16, 2011
    #2
    I got, what i believe to be the newest version of the feather just last week (says for the 4S)

    It is the olive drab color, so I dont know if that makes a difference.

    I would not say there is an issue with the flash. I took a couple of photos to test it in dark conditions and the photos look fine.
     
  3. LTMK macrumors member

    Joined:
    Apr 1, 2011
    Location:
    NY, NY
    #3
    I think the problem has been fixed.. mine is ok
     
  4. MotionxxUSxx macrumors 6502

    Joined:
    Jul 1, 2007
    #4
    I returned the white feather since the flash issue was still there.
     
  5. self thread starter macrumors regular

    Joined:
    Jul 11, 2008
    #5
    Do you know if that was the new design? You got it recently from myincipio.com?
     
  6. MotionxxUSxx macrumors 6502

    Joined:
    Jul 1, 2007
    #6
    Picked it up from Walmart last week. I'm assuming it was the new design. I'll check out myincipio.com.
     
  7. LMD75 macrumors 6502

    Joined:
    Oct 5, 2010
    #7
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Their website contains pictures of old and newer designs. The new one has an extra bar by the volume controls and the old one just has one big cutout.
     
  8. solo118 macrumors 65816

    Joined:
    May 16, 2011
    #8
    I had one with the bar (which broke by the way) so i got a replacement. So now I have the newest version for the 4S and it has no bar. It could just be an older version with a 4S sticker slapped on... who knows!
     

Share This Page