Incoming email to Sierra...

Discussion in 'macOS Sierra (10.12)' started by StarShot, Sep 20, 2017.

  1. StarShot macrumors 6502a

    StarShot

    Joined:
    Mar 31, 2014
    #1
    Recently I seem to have a problem with incoming email effecting several email accounts. For instance, I get email coming into my iPhone or iPad, but not to my MacBook Air. Today I discovered IF I close down the email accounts on my MBA and then open it again, email that already arrived on my iPhone and iPad suddenly downloads.

    Along these same lines, up until recently, if a text or email came in, I could see it on all three devices. That also doesn't happen anymore. I'm wondering if I accidently turned something off so that I'm not sharing my email/text with all my devices.

    Anyone have an idea as to what is going on here? My MBA, iPad and iPhone all have the latest software installed.
     
  2. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    As to paragraph #1...what is your setting in Mail for "Check for new messages:"?

    For paragraph #2...which devices, other than the MBA, aren't getting email and/or texts?
     
  3. StarShot thread starter macrumors 6502a

    StarShot

    Joined:
    Mar 31, 2014
    #3
    I don't see a item that says "Check for new messages" on my MBA or my iPad. Where would I find this opton
    Actually the problem 2 is that if I have my iPhone powered up and message comes in, it doesn't always repeat on my MBA where I find it much easior to reply to emails because of the MBA keyboard. I checked last night and all three devices (MBA, iPhone and iPad are signed in to the same icloud account.
     
  4. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    The preference setting is in Mail on the Mac at Mail>Preferences>General.
     
  5. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #5
    Verify the account is connected and not offline. You should see a symbol by the account if it's offline. Under Window in the Menu bar, select Connection Doctor. Do you see green for both incoming (IMAP) and outgoing (SMTP) for your iCloud account?

    Select the iCloud Inbox. Not the top unified Inbox that is not a real folder.
    Under Mailbox in the Menu bar, select Rebuild. This is the last option in the list. This will delete and download all messages from the server again.
     
  6. StarShot thread starter macrumors 6502a

    StarShot

    Joined:
    Mar 31, 2014
    #6
    I don't see "Check for new messages" in "Mail>Preferences>General".

    However, the problem seems to be going away.

    Thanks to all for trying to help with this problem.
     

Share This Page

6 September 20, 2017