Incompatible library version

Discussion in 'Mac Programming' started by anni.saini, Mar 3, 2010.

  1. anni.saini macrumors newbie

    Joined:
    Jul 15, 2009
    #1
    Hi,

    Anybody know how to solve this problem:

    My application is showing this error on MAC OSX 10.5.6 and below version.

    can anybody tell me how to resolve this problem?
     
  2. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #2
    I guess the most obvious question is are you sure you have version 39.0.0 or later of libpng?
     
  3. anni.saini thread starter macrumors newbie

    Joined:
    Jul 15, 2009
    #3
    It doesn't have, how do I upgrade that lib on Mac or using my application? Is there any setting available in XCode?
     
  4. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #4
    You'll have to download it yourself before you can link to it. Try here. After installing on your system, add the file to your Xcode Frameworks folder so it can link to it (file should be in your /Library/Frameworks/ folder after installation).
     

Share This Page