Incorrect number of file hard links

Discussion in 'OS X Mavericks (10.9)' started by pheon, Nov 13, 2013.

  1. pheon macrumors newbie

    Joined:
    Feb 17, 2013
    #1
    I have a MacBook Pro Retina, Mid 2012 running OS X 10.9 having recently upgraded.

    Using Disk Utility to Verify Disk it reported the following

    Checking file system
    Performing live verification.
    Checking Journaled HFS Plus volume.
    Incorrect number of file hard links
    Checking catalog hierarchy.
    Checking extended attributes file.
    Error: This disk needs to be repaired using the Recovery HD. Restart your computer, holding down the Command key and the R key until you see the Apple logo. When the OS X Utilities window appears, choose Disk Utility.

    I followed the instructions and the Disk Utility on the Recovery HD reports that the disk is OK.

    Rebooting and checking again with Disk Utility in my Admin account reports the same original error.

    Is this a problem? How do I fix it?
     
  2. SteveXi macrumors newbie

    Joined:
    Nov 14, 2013
    #2
    I had the exact same experience this morning, but on a macbook air.

    I turned off FileVault encryption, then restarted to the recovery partition, then ran the disk utility repair disk again, and now it seems to have fixed the problem.
     
  3. deleuze1 macrumors newbie

    Joined:
    Jul 16, 2008
    #3
    same problem. OSX 10.9 MacBook Pro retina 2012. disk verify shows incorrect number of extended attributes, then tells me to repair disk w/ Recovery HD. I do that, restart, but same error shows up in live verification. Not sure what to do..
     
  4. chikhao macrumors newbie

    Joined:
    Feb 5, 2010
    #4
    I had the same problem, but only after my cleanapp software crashed unexpectedly. The first time it occur, I had to fix the disk twice before the error was gone. The second time, I was able to fix the error once.

    I have deleted cleanapp for good.

    Can anybody report back did you see this message after some of your app broke or it's under completely normal usage?

    I am curious to see if it is solely caused by the software crash or something more severe.

    Thanks
     
  5. markjholloway macrumors newbie

    Joined:
    Oct 25, 2014
    #5
    Filevault is the problem

    I followed SteveXi's advice and it worked perfectly:

    "I turned off FileVault encryption, then restarted to the recovery partition, then ran the disk utility repair disk again, and now it seems to have fixed the problem."

    :)
     
  6. powers74, Nov 3, 2014
    Last edited: Nov 5, 2014

    powers74 macrumors 68000

    powers74

    Joined:
    Aug 18, 2008
    Location:
    At the bend in the river
    #6
    Oh crap. I'm getting

    "Orphaned file inode (id = 75597773
    Look for missing items in lost+found directory
    The volume 640 could not be repaired
    File system check exit code is 8
    Updating boot support partitions for the volume as required
    Error: disk utility can't repair this disk. Back up as many of your files as possible, reformat the disk and restore your backed-up files.

    Thank god for TimeMachine.

    Fingers crossed.

    Update: well, the disk repair & TimeMachine restore went off without with a hitch.

    :apple:
     
  7. jeffpickard macrumors newbie

    jeffpickard

    Joined:
    Jan 8, 2017
    #7
    Thanks SteveXi, this worked for my MacBook running Sierra 10.12.2..too!
     
  8. dnslong macrumors newbie

    Joined:
    Jun 28, 2017
    Location:
    Half Way, MO
    #8

    I had the same error (plus some others) when I ran First Aid on my MacBook Pro running macOS 10.12.5. Turning off FileVault encryption and re-running the disk utility fixed the problem! I thought I had a broken SSD. Thank you for sharing your fix!
     

Share This Page