Incorrect SIM message on 4.6 iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by sfsleeper, Feb 7, 2008.

  1. sfsleeper macrumors newbie

    Joined:
    Feb 6, 2008
    #1
    I just bought a new iPhone (baseband version 04.03.13_G, bootloader 4.6_M3S2), only to figure out afterwords that this version cannot yet be unlocked. OK, but then I found this thread: http://modmyifone.com/forums/showthread.php?p=170609 which said that you can use it with the Pay-As-You-Go plan. I followed those instructions, but, with the phone jailbroken in 1.1.1 or in 1.1.2, I continually get the "Incorrect SIM This iPhone must be used with an approved SIM" message. I've followed a few different jailbreak tutorials, and I never see the Incorrect SIM alert in the screencaps shown with the tutorials the way I have on my phone. This happened with the original SIM, the original SIM after I tried to activate it for PAYG on the AT&T site, and a fresh AT&T PAYG SIM.

    I've searched around for solutions for this, but I can never tell if people are referring to the new updated iPhones or the older unlockable version. Either way, I haven't come across any suggestions that have worked for me.

    If all else fails, I can try to upgrade back to 1.1.3 and try to fail the credit check with 999-99-9999 (though that didn't work when I tried it at first, before all the jailbreak stuff) to get the month-to-month option.

    Any suggestions are appreciated!
     
  2. munroe macrumors regular

    Joined:
    Nov 14, 2007
    Location:
    Ireland
    #2
    I think Apple might have plugged that hole with baseband version 04.03.13_G. The thread you mention was for the earlier versions.

    Also, they have fixed the 999-99-9999 social security number bug, so that won't work.

    There are rumors of a new SIM sandwich solution that works on OOTB 1.1.3 - xSIM v6.0 or v7.0, I think. You might check into that...
     

Share This Page