Incorrect track data on iOS

Discussion in 'iOS 8' started by Jackson2317, Jun 15, 2015.

  1. Jackson2317 macrumors newbie

    Joined:
    Jun 15, 2015
    #1
    After I sync my iPad Air 2 with iTunes, the track data on my iPad is different to that in iTunes.

    For example, when I sync "Do You Want The Truth Or Something Beautiful?" the album appears on my iPad as "Do You Want the Truth or Something Beautiful?"

    The same thing is happening with many of my other albums. It seems like my iPad might be substituting my own version of the song with my customised track data for the iCloud version of the song. In iTunes on my PC, the track data remains correctly tagged.

    All I want to do is to sync my own music as it appears on iTunes to my iPad without any changes being made. I am able to do this on my original iPad running iOS 5 but not on my iPad Air 2 running iOS 8.3.

    I have checked the sort data of my songs and this is correct. I have also tried syncing my iPad after signing out of iCloud and the iTunes Store. I don't know what else to try?
     
  2. jimthing macrumors 6502a

    jimthing

    Joined:
    Apr 6, 2011
    Location:
    London, UK
    #2
    Welcome to iTunes foibles!
    I too like to capitalise all words in titles, but the sync to iDevice often refuses to display my version.

    Pretty much still crap after Apple Music was announced, I was very nonplused by the lack of improvements to either proper and FULL metadata viewing in iOS, nor the lack of ALAC lossless optional purchase downloads.

    Welcome to the disappointing world of Apple and it's "music" offering.
     
  3. Jackson2317 thread starter macrumors newbie

    Joined:
    Jun 15, 2015
    #3
    Thanks for your help.

    I have now partially solved this problem by doing a backup and restore but this only works if I set up my device as a new iPad, meaning that I lose all my app data. I could have managed with this if it was possible to do a selective restore or to backup my app data through iExplorer, but the new security settings in iOS 8.3 prevent this!
     

Share This Page