Increase in shutdown time.

Discussion in 'MacBook Pro' started by LoganCircle, May 1, 2010.

  1. LoganCircle macrumors member

    Joined:
    Feb 18, 2010
    Location:
    Washington, DC
    #1
    On my recently purchased macbook pro, the shutdown time had been about 4 or 5 seconds.

    Earlier this week, I plugged in a Sprint Smartview aircard to use for work. The card installed software to get it working. Since that moment, my MBP takes about 20-30 seconds to shut down.

    I have since uninstalled the software, hoping that it'd return to the 4-5 second shutdown. Alas, it has not.


    I've tried running ONYX and using the Disk Utility to repair permissions.

    Any advice on where to look or what to do to clean this up and get it back to the 4-5 second shutdown? I'm new to the mac world, please help.
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
  3. JimAtLaw macrumors 6502

    Joined:
    Sep 26, 2006
    Location:
    Bay Area, CA
    #3
    I've noticed that mine goes to sleep instantly when by itself, but takes several seconds if I have the 24" ACD plugged in. Perhaps the software is trying to shut down the card - is the card plugged in at the time? Have you tried it both ways?
     
  4. diablo2112 macrumors 6502

    Joined:
    Apr 16, 2010
    #4
    I've just this week had the exact same issue on my 15" i7 w/Intel SSD. In addition to an increase in the shutdown time to about 40 seconds (from 3), it also refused to boot. I had to hold the option key to get the drive to even be recognized.

    I ran disk utility, fixed the permissions, and this cleared up the boot problem but one time in about 5, it stil hangs on shutdown, taking 40 sec or so instead of 3.

    Would love to know a more permanent solution to this of if others have had it.
     
  5. flat five macrumors 603

    flat five

    Joined:
    Feb 6, 2007
    Location:
    newyorkcity
    #5
    it might be an app you have open.
    there are times when i have a shoddy internet connection and mail.app will hang when trying to close it.. that same hang affects shut down as well and will occasionally prevent it from happening at all.
    try closing all your apps first then see if the delay still happens.
     
  6. LoganCircle thread starter macrumors member

    Joined:
    Feb 18, 2010
    Location:
    Washington, DC
    #6
    I tried this. It didn't work.
    Also, I do close all applications before shutting down.
     
  7. LoganCircle thread starter macrumors member

    Joined:
    Feb 18, 2010
    Location:
    Washington, DC
    #7
    Fixed. I found this:

    Back down to 4-5 seconds.
     
  8. JimAtLaw macrumors 6502

    Joined:
    Sep 26, 2006
    Location:
    Bay Area, CA
    #8
    So how would that happen? Wouldn't the installer for your card have to have changed the properties of the root directory expressly? Seems like a very odd behavior, I can't imagine why any app would need to do this...
     
  9. WisdomWolf macrumors regular

    Joined:
    Apr 15, 2010
    #9
    This thread has been most helpful. I love my mac, but I thought something was horribly wrong when I tried to shut it down last night and it kept going for over 5 minutes before I had to just force it to shutdown. Fixed the permissions as suggested and it now shuts down in 5 seconds flat. Thank you! :D
     
  10. gpjiki macrumors newbie

    Joined:
    Jul 30, 2010
    #10
    Password?

    After opening and typing the first command
    I cannot enter my password
    my keyboard wont type in anything except for the ENTER button
    do you guys have any tips?
     
  11. warrmr macrumors regular

    Joined:
    Jul 7, 2010
    #11
    Its supposed to do that. It is just a *nix thing that happens. Just cary on typing your password press enter and it should continue. if you misstype it just press enter and it will give you 2 more chances.
     
  12. Syonidism macrumors regular

    Joined:
    Feb 10, 2009
    Location:
    Turkey
    #12
    my new mbp with i7 and 256gb ssd shuts down in less than a second. it starts up within 3seconds.


    i love it.
     
  13. mekump macrumors newbie

    Joined:
    Jun 25, 2010
    #13
    great thread.

    i noticed some time ago my laptops became slow to shut down. noticed the following mesg in the system.log when i would shut the laptops down.

    com.apple.kextd[10]: Can't create kext cache under / - owner not root.

    made my root directory identical to my root directory on my imac by issuing the following commands .......

    cd /
    sudo chmod 1775 .
    sudo chown root:admin .

    didn't issue the kextcache commands because i really don't understand what they do. i powered off my laptop and it was a big difference. powered off in a few seconds the way it used to.
    when i powered the laptop back up i checked the system logs for any references to kextcache and didn't see any. so, for now i don't plan to issue the kextcache commands.

    i wonder if one of the apple s/w updates changed the root directory.

    mike
     
  14. RKpro macrumors 6502

    Joined:
    Oct 27, 2008
    #14
    I know this is an old thread, but wow! Thanks LoganCircle.

    I had an intel x-25m ssd for the past 8 months, and it would take about 2 seconds to shutdown while the osx install was fresh, but over the next few weeks it would always slow down to like 10 seconds or more. It was still brazing fast at opening apps and in benchmarks, but start up and shutdown really became slow.

    Now thanks to this thread it takes 2 seconds to shutdown, and I think it shaved 10 seconds from my startup time as well.
     
  15. glavoie84 macrumors regular

    Joined:
    Jun 23, 2009
    #15
    Slowdown on boot and shutdown happened to me since the 10.6.5 update. Boot time went from 15 secs to 30-35 secs with my X25-M. I also found that my / directory wasn't owned by root anymore. Issuing the "chown" command solved the problem for me too!
     
  16. RKpro macrumors 6502

    Joined:
    Oct 27, 2008
    #16
    It happened to me again since my post last week, somehow the ownership of the root directory changed, and my shutdown/boot times increased dramatically. It was a quick fix thanks to those three terminal commands, but I just find it really strange.

    I was a bit paranoid, and scanned my entire hard drive with sonos free anti-virus, but it found no threats.

    I don't remember installing any new software in the past week, but there very several instances when I was asked for my password by some apps and osx. I suspect this is when the ownership changes. I'll pay more attention next time, so see if I can isolate the cause of this.
     
  17. Smacky macrumors 6502

    Joined:
    Jul 23, 2008
    #17
    I have two machines, after installing 10.6.5 I noticed an increase in both boot and shutdown times with the spinning wheel on a grey or blue screen
    Using the terminal commands above fixed it
     

Share This Page