Indesign EPS Import

Discussion in 'Design and Graphics' started by dazzer21, Oct 2, 2008.

  1. dazzer21 macrumors 6502

    Joined:
    Oct 18, 2005
    #1
    Just getting to grips with InDesign - shaken off the Quark 7 shackles - Yay!!

    When I import an Illustrator EPS file, it comes in with a white background. If I open that file in Illustrator and then copy and paste it into Indesign, it works OK. It comes in as editable as well (which I really don't need) but when the images I'm using are mainly white anyway, and need to be placed transparently, to not be able to import them directly with the desired result isn't ideal. No doubt this is something really simple and I'll smack myself hard on the forehead when I get the solution, but as a noob it's a little frustrating. Can't wait until I'm as proficient at this as I am in Quark...
     
  2. shawnathan macrumors member

    shawnathan

    Joined:
    Mar 31, 2008
    #2
    This happens to me sometimes too. You can save your EPS as an Illustrator.ai file instead and place that into InDesign. Being that InDesign and Illustrator are both made by Adobe, they are 100% compatible... unlike Quark "Crash" Express.
     
  3. Infinitygraphix macrumors member

    Joined:
    Apr 14, 2008
    #3
    Your a re working in « normal mode »
    When printing there will be no white background on your image (if you don't select a white background in the color palette)
    To see without the white background in InDesign, select the menu View on the top and clic « Overprint preview »

    Or instead of « Overprint preview » you can go to « Display performance » in the View menu and select « High quality display »
     
  4. design-is macrumors 65816

    design-is

    Joined:
    Oct 17, 2007
    Location:
    London / U.K.
    #4
    Infinitygraphix is correct, you are seeing it as a preview and it hasn't rendered the transparency. Go to full quality view and you should get your transparency :)
     
  5. Kwill macrumors 68000

    Kwill

    Joined:
    Mar 10, 2003
    #5
    It can also depend upon EPS options when saving file from Illustrator. There is a Transparent selection available when saving TIFF (8-bit Color) images. On a Mac, the default preview option is Macintosh (8-bit Color) with transparency (PICT). However, for cross-platform support, TIFF is recommended.

    Under some circumstances PDF is a better format for retaining transparency between Creative Suite applications.
     

    Attached Files:

  6. dazzer21 thread starter macrumors 6502

    Joined:
    Oct 18, 2005
    #6
    Checked the EPS files. They do have the transparency option checked (although I've never even had to bother to look at that option when using Quark). I've also had a look at the Preview Screen option and still there are white boxes. Have checked the links too - all okay!
     
  7. Infinitygraphix macrumors member

    Joined:
    Apr 14, 2008
    #7
    Just to make sure.... Did you check that the box where your artowork is placed doesn't have a white background by default ? The background color of the box where the image is should be set to « none »
     
  8. dazzer21 thread starter macrumors 6502

    Joined:
    Oct 18, 2005
    #8
    Yep - both the fill and the stroke show nothing there (red diagonals)
     
  9. jerryrock macrumors 6502

    jerryrock

    Joined:
    Sep 11, 2007
    Location:
    Amsterdam, NY
    #9
    In the "Place" dialog box, make sure that "show import options" is checked.

    Before the selected file is placed you will get another dialog box allowing you to import with transparent background.
     

    Attached Files:

  10. dazzer21 thread starter macrumors 6502

    Joined:
    Oct 18, 2005
    #10
    I notice that you're importing an .ai file. I'm importing an Illustrator EPS and the secondary window is different to the one you've shown. I get:

    [] Read Embedded OPI Image Links
    [] Apply Photoshop Clipping Path

    Subhead - Proxy Generation

    o Use TIFF or PICT Preview
    o Rasterize the Postscript
     
  11. smurfjammer macrumors 6502a

    smurfjammer

    Joined:
    Jun 7, 2004
    Location:
    Auckland, New Zealand
    #11
    Don't save it as an .EPS, just use the .AI (converting to .EPS is a Quark hang up that you don't need to do since your using InDesign)
    With Indesign you can just place .AI and .PSD without having to export as .EPS or .TIFF - saves a few steps and gives you more options.
     
  12. dazzer21 thread starter macrumors 6502

    Joined:
    Oct 18, 2005
    #12
    If it wasn't for the fact that I'm the only one using InDesign in a pool of 5 designers who are still all using Quark (losers!), I'd be able to go down the .ai route without any problems. They need access to my files and as they are using various different versions of Quark, I'm stuck with following the crowd...
     
  13. Infinitygraphix macrumors member

    Joined:
    Apr 14, 2008
    #13
    EPS file are not the problem here.

    I work with InDesign and I never had this problem even if I'm still always using EPS file. I don't have any problem with white background like you mentionned. So actually it is not the EPS file format the problem.

    Do you have anything in the Illustrator file that is rasterized ?

    I ask beceause this makes me wonder :

    [] Read Embedded OPI Image Links
    [] Apply Photoshop Clipping Path
     

Share This Page