InDesign font question - URGENT! Please HELP!!!

Discussion in 'Mac Apps and Mac App Store' started by Apple!Fre@k, Nov 20, 2009.

  1. Apple!Fre@k macrumors 6502a

    Joined:
    Jun 25, 2006
    #1
    Just upgraded to a new 27" quad-core iMac and migrated all of my files over. I was in the middle of a huge InDesign project and have over 30 InDesign files that I created on my old 24" iMac. Now, here's the problem:

    When I open any of those InDesign files on my new iMac, it tells me that two fonts are missing: Gill Sans (T1) Bold and Gill Sans (T1) Regular. How that happened, I have no idea. But those are the two fonts I use most throughout all 30 files, which results in 199 errors for each file because of those two "missing" fonts. Now when I try and change the font to Gill Sans Bold and Gill Sans Regular (not the T1), it's identical, but the spacing is a fraction of an inch larger which results in dozens of words on each file being pushed to the next line, obviously resulting in chaos.

    Anyone have any idea what's going on here and how to rectify it. On my 24" iMac, I was using Leopard and now the new 27" I'm on has Snow Leopard if that makes a difference with the installed fonts -- but all my files were migrated over via auto Firewire transfer so the two systems should be identical!

    I'd be super appreciative if you could help because right now, I'm screwed! :(

    [​IMG]
    [​IMG]
     
  2. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
  3. johnmadden78 macrumors member

    Joined:
    Dec 19, 2008
    Location:
    Dublin, Ireland
    #3
    I've had similar problems resolved by installing Linotype FontExplorer (it's a free download) and using the 'resolve conflicts' function or just by disabling and reenabling the correct version of the font (making sure any duplicate or alternate versions of the font are disabled first).

    I know they sound painfully obvious, but it's as much as I can offer at this point. Sorry. Hope you get it resolved somehow.
     
  4. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #4
    Eureka! I've figured it out. My new iMac automatically disabled duplicate fonts and I had two versions of Gill Sans Regular and Gill Sans Bold. It choose the T1 version to auto disable. One which was True Type and the other which is Post Script Type 1 (T1)! I just reversed the two so the True Type was disabled and T1 versions active and I'm all set. No more errors. Thanks for making me dig deeper!
     
  5. smartmediaman macrumors newbie

    Joined:
    Dec 7, 2009
    #5
    So How did you Fix this Issue?

    I am having the same issue with my Gill Sans (T1), my Helvetica Neu family, and my Linotype Didot family as well. What were the exact steps you took to overcome this issue? Any help from anyone on on this form would be seriously appreciated.

    Thank you kindly.

    Smartmediaman@gmail.com
     
  6. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #6
    God, I'm glad I posted this some six months ago. I just updated to 10.6.4 and ran into the exact same problem (guess 10.6.4 makes changes to the Font Book). Totally forgot about how I corrected it before so I ran a Google search and found this post reminding myself how I did it. Gotta love Google. :)
     
  7. Apple!Fre@k thread starter macrumors 6502a

    Joined:
    Jun 25, 2006
    #7
    Open Font Book in your Applications folder and navigate to the fonts you are having the errors with, then play around with disabling and/or enabling them. After each change in the Font Book, reopen the application you're working with so it can update -- in this case, InDesign. All I had to do with disable the duplicate versions of the style of the font I was using, close and reopen InDesign and presto. :)
     

Share This Page