index.xml file missing

steve jr.

macrumors 6502
Original poster
Jul 4, 2005
330
4
Akron, OH
Hello. I backed up all my files and did a clean install of leopard. I dumped my files and now, when I try to open a Pages document, I get: "Unable to open “insert_filename_here” because the document is invalid. The index.xml file is missing."

Any suggestions? And I have noticed some of the files work, and others don't. Seems to be about 50/50. Same with all my Keynote files, except it just says the file is damaged.

Any and all help is appreciated!

Thanks,
Steve
 

QSurferQ

macrumors newbie
Jan 5, 2010
1
0
Finally a solution which worked for me!

I tried all the other suggested solutions for the dreaded "The index.xml file is missing" error when trying to open a corrupted Pages document. I had tried all the suggestions from 2007 to 2009 with no luck.

Then, the last one I came across recommended renaming the file from "[file name].pages" to "[file name].pages.zip" and then opening it on my Mac. I tried this, but it still didn't work. So I emailed the file to myself at work where i use PC's, and lo and behold I was able to open the file with the intrinsic Windows XP Compressed Folders. I assume that this could probably be done in Windows in Parallels as well, and other applications like Winzip might work just as well as the Compressed Folders in Windows XP.

After opening it, I found the .pdf preview file (Thanks heavens for saving a preview in the Pages document) and I sent this back to myself at my Mac. Voila! I opened the PDF in Preview, copied, and pasted the text back into a Pages document (with saved preview!). Hope this helps!

EM
 

Yidaki

macrumors newbie
Jul 5, 2009
15
6
Solution: You're on the right track but windows not necessary

I tried all the other suggested solutions for the dreaded "The index.xml file is missing" error when trying to open a corrupted Pages document. I had tried all the suggestions from 2007 to 2009 with no luck.

Then, the last one I came across recommended renaming the file from "[file name].pages" to "[file name].pages.zip" and then opening it on my Mac. I tried this, but it still didn't work. So I emailed the file to myself at work where i use PC's, and lo and behold I was able to open the file with the intrinsic Windows XP Compressed Folders. I assume that this could probably be done in Windows in Parallels as well, and other applications like Winzip might work just as well as the Compressed Folders in Windows XP.

After opening it, I found the .pdf preview file (Thanks heavens for saving a preview in the Pages document) and I sent this back to myself at my Mac. Voila! I opened the PDF in Preview, copied, and pasted the text back into a Pages document (with saved preview!). Hope this helps!

EM
Essentially the .pages file is a folder but Apple makes it no longer seen as one so 'Show Package Contents' is not an option in the contextual menu (right-click). To resolve this error you NEED to have the index.xml file present at the top of the pages package.

SOLUTION: rename the file to .zip. Double-click this file to unzip and you should now have:
Code:
nameoffile
as a folder in the same location. Open that folder and:
1. If the
Code:
index.xml
file is already there it may have just been inaccesible due to file not being saved completely the last time. Rename folder to '
Code:
nameoffolder.pages
', reopen in Pages and hopefully it should work.
2. If the
Code:
index.xml
file is missing, I've read elsewhere that there should be a index-new.xml file that you can rename and follow the rest of the procedure in Step 1.
3. #1 solved it for me so beyond this I'm not sure, perhaps you could borrow this index.xml file from another pages document to recover at least something from a working file.
 

uniteach

macrumors newbie
Nov 21, 2010
1
0
Thank you it worked

I do appreciate your solution Yidaki. My file is now open in Pages.

Kind regards
Wayne :D
 

racooper

macrumors newbie
Aug 22, 2014
1
0
Need help

All my pages documents on my desktop will not open as of today. I get the message that the index.xml is missing. I've tried to rename document.pages to document.zip but then I can't double click it because it turns into a folder and there are no files with the name of my document in it.

What happened to cause this and can anything short of swearing off Apple computers help?
 

Rembo

macrumors newbie
May 4, 2015
1
0
This index.xml fix worked for me

I discovered the index.xml / Pages problem only today – couldn't open any files created in or before August 2014. As these forums are always very helpful, I thought I would share the fix that worked for me (after trying many others).

The problem: Pages 5.2.2 in OS 10.9.5 does not open Pages documents previous to iWork upgrade of August, 2014.

Pages 5 says: "file cannot be opened" (not very informative). Pages 4 says: "index.xml file is missing" (a bit more helpful).

What worked for me: go to the file. Open the file package (right-click the file), unpack the index.zip file (double click it). Then back to the problematic file, double-click, open sesame.

There are a lot of fixes floating around. I guess with different versions of documents and Pages-upgrades different fixes are necessary.
 

Mick Robson

macrumors newbie
Feb 24, 2016
1
0
Finally a solution which worked for me!

I tried all the other suggested solutions for the dreaded "The index.xml file is missing" error when trying to open a corrupted Pages document. I had tried all the suggestions from 2007 to 2009 with no luck.

Then, the last one I came across recommended renaming the file from "[file name].pages" to "[file name].pages.zip" and then opening it on my Mac. I tried this, but it still didn't work. So I emailed the file to myself at work where i use PC's, and lo and behold I was able to open the file with the intrinsic Windows XP Compressed Folders. I assume that this could probably be done in Windows in Parallels as well, and other applications like Winzip might work just as well as the Compressed Folders in Windows XP.

After opening it, I found the .pdf preview file (Thanks heavens for saving a preview in the Pages document) and I sent this back to myself at my Mac. Voila! I opened the PDF in Preview, copied, and pasted the text back into a Pages document (with saved preview!). Hope this helps!

EM
Hi QSurferQ. I've just signed up so I could feedback about what happened to me a few minutes ago...your fix seemed quite logical and got me moving as I have Word for Mac on my Air, so I e mailed the files (two) that wouldn't open, to myself as attachments on Outlook. Haven't opened the e mailed attachments yet, but after closing my e mail page on my Mac OSX I clicked on the original files again and they both opened. I don't know what's happened in that procedure, but I'm no longer getting the xlm index missing pop up and I'm working on the original texts. So...thanks at least for a push in the right direction, for me.
 

soreilly55

macrumors newbie
Dec 17, 2016
1
0
Hello. I backed up all my files and did a clean install of leopard. I dumped my files and now, when I try to open a Pages document, I get: "Unable to open “insert_filename_here” because the document is invalid. The index.xml file is missing."

Any suggestions? And I have noticed some of the files work, and others don't. Seems to be about 50/50. Same with all my Keynote files, except it just says the file is damaged.

Any and all help is appreciated!

Thanks,
Steve
I've recently upgraded to Sierra and only just come across this problem when using Pages 4.0.9

It seems to have been solved by NOT including preview when saving—unclick the "include preview in document by default" in Preferences: General: Saving. I never used preview anyway, but this is a BLOODY nuisance — why hasn't Apple fixed it yet?
 

neelyjon

macrumors newbie
Jan 4, 2017
2
0
Altoona, PA
I've recently upgraded to Sierra and only just come across this problem when using Pages 4.0.9

It seems to have been solved by NOT including preview when saving—unclick the "include preview in document by default" in Preferences: General: Saving. I never used preview anyway, but this is a BLOODY nuisance — why hasn't Apple fixed it yet?
I solved the issue by going to file: "Export as." Once I exported the pages file as "pages 09" the error message "index.xml file missing" went away and the file opened fine. Sometimes the simplest solutions are the best. I was trying to open a pages document I prepared on Sierra on my old mac running Leopard.
Now I can.
 

abby1221

macrumors newbie
Jan 6, 2017
1
0
I solved the issue by going to file: "Export as." Once I exported the pages file as "pages 09" the error message "index.xml file missing" went away and the file opened fine. Sometimes the simplest solutions are the best. I was trying to open a pages document I prepared on Sierra on my old mac running Leopard.
Now I can.
Hi, I'm having this same issue - but I can't go to "File" and "Save As.." since I can't open the document in the first place. Any suggestion?
 

neelyjon

macrumors newbie
Jan 4, 2017
2
0
Altoona, PA
Where did the file you are trying to open come from? Have it's format changed at it's source, or find someone running Sierra and have them reformat it for you. The command from file is actually "Export to." You might also try an online file converter. I just did a conversion from my newer pages to pages 09 on Zamzar. It worked! What version are you running on your computer? Can you move up?
 

Similar threads

Replies
1
Views
352
  • mac_in_tosh
12
Replies
12
Views
608
  • tranceking26
8
Replies
8
Views
950
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.