Indexing A Networked Drive

ethan-1878

macrumors member
Original poster
Jun 8, 2014
45
1
Hi All,

Not sure if this is the correct place for this post but I apologise if it's not. Nonetheless, I'm sure somebody here will have a solution for me.

I've just set up a Synology NAS and I am trying to force spotlight to index my NAS. I have tried using the following command:

Code:
sudo mdutil /Volume/Volume\ Name -i on
but terminal keeps giving me this response:

Code:
/Volumes/Volume Name:

    Indexing disabled.
I have tried running
Code:
sudo mdutil /Volume/Volume\ Name -s
to check whether it is enabled or not in case it was a strange Finder glitch but that gives the same response.

If I try to disable indexing using
Code:
sudo mdutil /Volume/Volume\ Name -i off
I get this response:

Code:
2016-12-08 15:04:02.923 mdutil[3240:1772539] mdutil disabling Spotlight: /Volumes/Volume Name -> kMDConfigSearchLevelFSSearchOnly

    Indexing disabled.
Does anyone know what's going on here and why I can't enable indexing?

Thanks in advance,

Ethan.
 

belvdr

macrumors 603
Aug 15, 2005
5,660
1,001
No longer logging into MR
Not sure if it matters, but the usage of the command is:

Code:
Usage: mdutil -pEsa -i (on|off) -d volume ...
So, does this work?

Code:
mdutil -i on /Volumes/<VolName>
It's quite possible that it won't work on network volumes, for good reason.
 

ethan-1878

macrumors member
Original poster
Jun 8, 2014
45
1
Not sure if it matters, but the usage of the command is:

Code:
Usage: mdutil -pEsa -i (on|off) -d volume ...
So, does this work?

Code:
mdutil -i on /Volumes/<VolName>
It's quite possible that it won't work on network volumes, for good reason.

Nope, doesn't work. I have used this before and it's worked fine. Exactly the same set up too.
 

Mufasa804

macrumors regular
Mar 6, 2009
229
75
I'm curious to see if anyone provides a fix. From my understanding, OS X will not index of networked volumes.
 

ethan-1878

macrumors member
Original poster
Jun 8, 2014
45
1
I'm curious to see if anyone provides a fix. From my understanding, OS X will not index of networked volumes.
I don't have access to the NAS I have set up to index as it is in a secondary office which I'm no longer at full time but it did work. I could spotlight search any file on the mounted share. This was enabled under Yosemite or El Capitan though.

Curious as to why it won't let me enable spotlight indexing under Sierra.

Hope someone out there knows the answer to this!
 

belvdr

macrumors 603
Aug 15, 2005
5,660
1,001
No longer logging into MR
I don't have access to the NAS I have set up to index as it is in a secondary office which I'm no longer at full time but it did work. I could spotlight search any file on the mounted share. This was enabled under Yosemite or El Capitan though.

Curious as to why it won't let me enable spotlight indexing under Sierra.

Hope someone out there knows the answer to this!
It doesn't work on my El Capitan machine connected via SMB. I wonder if it's a protocol thing.
 

ethan-1878

macrumors member
Original poster
Jun 8, 2014
45
1
I'm curious to see if anyone provides a fix. From my understanding, OS X will not index of networked volumes.
See the below article. OS X does support indexing network shares but only those mounted via AFP (I already knew this also was using AFP anyway).

http://apple.stackexchange.com/questions/164443/does-os-x-yosemite-support-spotlight-on-network-drives
[doublepost=1481230199][/doublepost]
It doesn't work on my El Capitan machine connected via SMB. I wonder if it's a protocol thing.
Yeah, I've just posted a stack exchange thread above explaining this. I knew about that though so I use AFP anyway.

The NAS in question are both synology DS216j's and I connect to both using AFP.
 
Last edited:

ethan-1878

macrumors member
Original poster
Jun 8, 2014
45
1
I bet it takes ages... My 8TB array hooked up to a Mini Server with FW800 (yeah, I know, should've bought an array with TB) indexed for like 3 days...
Terminal tells me that indexing is disabled even when I try to force spotlight to index the networked drive. I've also tried adding the drive to spotlight exclusions then removing it again but there's doesn't help. Spotlight doesn't even begin to index the drive.
 

starion

macrumors newbie
May 11, 2008
2
0
I know this is quite a bit down the road since the original post, but here's what I have discovered recently (probably old news to many of you):

Spotlight does seem to index networked SMB volumes in High Sierra 10.13.4.

The problem I have run into though, is that if the network volume disappears, then shows up again, Spotlight gets disabled and has to be re-enabled again (via terminal) for that volume.

Does anybody know of a way to make this stick between mounts/unmounts of the network volume?
 

jdmagoo1

macrumors regular
May 5, 2010
178
77
I know this is quite a bit down the road since the original post, but here's what I have discovered recently (probably old news to many of you):

Spotlight does seem to index networked SMB volumes in High Sierra 10.13.4.

The problem I have run into though, is that if the network volume disappears, then shows up again, Spotlight gets disabled and has to be re-enabled again (via terminal) for that volume.

Does anybody know of a way to make this stick between mounts/unmounts of the network volume?
Thats a very good question and one I would like to know.

By the way, how did you get it to index and SMB structure