Indexing on every restart? Performance killer!!!

Discussion in 'Mac OS X Lion (10.7)' started by alexxk, Jul 20, 2011.

  1. alexxk macrumors 6502

    Joined:
    Jul 29, 2010
    #1
    I'm loving Lion so far but I noticed that every time I restart my macbook the indexing will kick in..

    It already did a full indexing and now every time I restart it does it again and takes about 20 minutes each...

    This is killing performance on my macbook. I know this is not normal, cause SL never did that..

    Is there a fix?
     
  2. mrapplegate macrumors 68030

    Joined:
    Feb 26, 2011
    Location:
    Cincinnati, OH
    #2
    Are you sure the index finished? It should not start each restart.
     
  3. monaarts macrumors 65816

    Joined:
    Jan 16, 2010
    Location:
    Kennesaw, GA
    #3
    SL did something similar when I installed it on my Leopard computer. Basically, it will keep doing that and slowly get better... Should take a day at most. It helps with faster performance later! ;-)
     
  4. psxtreme macrumors member

    Joined:
    Jun 27, 2009
    #4
    Mine is also indexing like crazy, I realized that it was trying to index my bootcamp partition even though I had it excluded in SL (had to exclude it again).
     
  5. alexxk thread starter macrumors 6502

    Joined:
    Jul 29, 2010
    #5

    Well it did take about 1 hour or more and the search icon stopped with that animation.... I'll leave my macbook on for some hours straight and see what happens.. right now its indexing again for over 20 min...
     
  6. DustinT macrumors 68000

    DustinT

    Joined:
    Feb 26, 2011
    #6
    Don't worry about it. It can take quite a long time to index, especially if you setup the new email client or bring in some documents.
     
  7. psxtreme macrumors member

    Joined:
    Jun 27, 2009
    #7
    I just realized you can see the progress and estimated time to completion of you click the spotlight icon.
     
  8. trashsteve macrumors newbie

    Joined:
    Apr 29, 2011
  9. runebinder, Jul 24, 2011
    Last edited: Jul 24, 2011

    runebinder macrumors 6502a

    runebinder

    Joined:
    Apr 2, 2009
    Location:
    Nottingham, UK
    #9
    I was just about to post a topic on this issue and saw this. Mine did the initial indexing Wednesday night, then again on Friday, and was just indexing again now. On Friday and just now it has caused my MBP to lock up with a spinning beach ball, I can move the cursor about but that's it and had to do a hard rest on both occasions.

    For the other people who have had this did you do an upgrade or clean install? I did an upgrade.

    Also do you use a SSD or a mechanical HDD?
     
  10. trashsteve macrumors newbie

    Joined:
    Apr 29, 2011
    #10
    I did upgrade also..this is my 5th time indexing. :mad:
     
  11. Pherkad macrumors newbie

    Joined:
    Dec 14, 2010
    #11
    After rebooting

    I'm seeing the re-indexing after each time the computer is rebooted. Letting spotlight finish, the computer is fine for a while. If it's rebooted, the whole process seems to start over again.
     
  12. trashsteve macrumors newbie

    Joined:
    Apr 29, 2011
  13. iBunny macrumors 65816

    Joined:
    Apr 15, 2004
    #13
    I did a clean install and Lion indexed once on first boot.... It has never done it since.
     
  14. kdfukuyama macrumors newbie

    kdfukuyama

    Joined:
    Jul 26, 2011
    Location:
    Brazil
    #14
    Mine is clear install and indexing on every boot. It takes about 10 seconds and stop :rolleyes:
     
  15. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #15
    Spotlight's insistence on re-indexing after every reboot has been driving me nuts for about six weeks. It brought my machine to its knees. Early 2010 MBP, 2.66GHz, 8GB RAM, Seagate Momentus XT 500GB drive running SD28 firmware, OS X Lion 10.7.4, no Boot Camp partition.

    I tried the terminal tricks referenced in this and other threads to reset Spotlight's index:

    Turn indexing off for /
    sudo mdutil -i off /

    Clear the metadata store for /
    sudo mdutil -E /

    Turn indexing back on for /
    sudo mdutil -i on /
    ...No help. (Took its sweet time, too.)

    I ran Disk Utility and found some errors on my drive. Rebooted in the Recovery Partition and used Disk Utility there to fix them.

    ...No help.

    Finally I began to suspect that the issue's onset may have coincided with my installation of Sophos' free antivirus utility for the Mac in the days after the Flashback kerfuffle. Now, I'd turned off Sophos' on-access scanning after initially scanning my disk, but given others' warnings about Intego's antivirus utility, I wondered if Sophos might have been contributing to this issue somehow. So I uninstalled it (using the uninstaller app that Sophos provided), and rebooted.

    AND IT WORKED.

    No re-indexing! No glacial performance affliction for eons after restarting!

    It's early yet, so we'll just have to see if subsequent reboots also go well. But this is the first reboot in weeks that hasn't had me gnashing my teeth in frustration.
     
  16. Alameda macrumors 6502a

    Alameda

    Joined:
    Jun 22, 2012
    #16
    Solution: Don't reboot your computer. It's not necessary.
     
  17. Puevlo macrumors 6502a

    Joined:
    Oct 21, 2011

Share This Page