Inexplicable problem when installing Snow Leopard via USB HD

Discussion in 'macOS' started by maidenseye, Sep 22, 2010.

  1. maidenseye macrumors newbie

    Joined:
    Sep 22, 2010
    #1
    Hi there!

    So for many years now I've been installing my OSX versions via an external drive. This includes Tiger, Leopard, and now of course Snow Leopard. Always loved this method as there is no need for any discs and the wait time is shorter.

    Now, recently I got a brand new Macbook Pro (i7, 4GB RAM, etc) and I was getting this weird feel from using the preinstalled version so I decided to simply reinstall using the retail image/disc I had used for all my other, older Mac computers.

    My usual tested process is as follows:

    1. Took an authentic retail Apple OSX Snow Leopard DVD and saved it as image.

    2. Using "Carbon Copy Cloner", expand the image into a partition my external USB drive.

    No problems so far, everything working like clockwork.

    3. I restart my new MBP, hit option--everything shows up fine--click the OSX bootable image and it moves right to the expected "Grey/White Apple Boot Logo"...

    ...and then stays there for 15 minutes (with no activity indicated by the external drive) until I just restart cold.

    Ummm ok... so let me try with one of my older computers. A 2007 model MBP...

    Restart, boot from the image/partition. BAM! Instantly I get full activity from the USB drive and within 2 minutes I'm at the installation welcome screen.

    What.... the.... hell...?

    It has proven impossible to search for any similar threads/situations/google on this issue.

    What is going on? Do I have a faulty MBP? Is there a BIOS firmware issue. WTH?

    Please help me! Thank you, thank you!
     
  2. alust2013 macrumors 601

    alust2013

    Joined:
    Feb 6, 2010
    Location:
    On the fence
    #2
    Easiest way would just be to install from the disk, considering you have it.
     
  3. maidenseye thread starter macrumors newbie

    Joined:
    Sep 22, 2010
    #3
    That's certainly an option.

    It's weird, I know, but considering that my system has been working a bit strange, I'm a bit distrusting of the included install discs.

    Does Mac OSX have different kernels, in the same way Linux does? For example, even if you install the same "Ubuntu 8" on a PC, you still have various options in choosing the kernel. Many people make custom versions and such, and I have experience where certain kernels didn't work as well as others--even though it's the same Ubuntu 8 overall.

    Overall my new MBP has been running a bit choppier and sometimes slower than my old 2007 MBP (and the new MBP specs as you can imagine blow the old laptop out of the water, so why is this the case?).

    I'll give you an example... When running VLC to watch a film in full screen, I sometimes encounter errors (which I am certain are not encode errors or anything since I'm using a real DVD)... Then when I go to quit, everything sort of freezes for 30 seconds... then it finally exits. But from then on my system is EXTREMELY laggy and choppy. I mean opening a finder window takes 15 seconds... and opening TextEdit has the icon bouncing in dock for 20-30 seconds when normally it's near instant.

    None of this, of course, ever happened in my old 2007 MBP--yet the specs of that computer are like 1/8 the power of the newer one.

    Could it be that it's a hardware issue? I really dislike problems that are seemingly impossible to troubleshoot, and before I go to the Apple store to complain--I want to make sure I know what I'm talking about. My first step was to reinstall the OS.

    And yes, I've repaired disk permissions, cleared cache... all that fun stuff. (I ran a full maintenance script from Onyx).

    I realize that is a bit off topic, but the truth is I would appreciate advice in either category since they are related.
     
  4. davidlv macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #4
    You should be using the Mac OS X Install DVD that came with the i7 MBP, not the retail SL DVD. The latest version of the retail DVD, ver 10.6.3 may work but it still doesn't have all the drivers, etc, required for the new machines. There is a big difference in the DVDs. You will have to use the 10.6.4 combo update and do the rest of the updates from the System Preferences, even if you get that USB HD install to work with the 10.6.3 install DVD.
    As to methodology, why use a disk image and CCC (which I have found to be very useful, but it does leave a disk that has many minor errors, which may be critical in a system install situation. Just guessing here, but when I run Disk Warrior on a disk that has just been cloned with CCC, it will always pop up several lines of red ink, which may be minor errors.)
    Anyway, you can just mount the install DVD, and the USB HD and use Disk Utility to "restore" the DVD to a partition on the USB HD (10 GB is enough).
    When I did that, the resulting partition showed no red ink whe running DW on it.
    In conclusion, your main problem is the DVD install disk (probably 10.6.0) is not up to date enough for the new MBP line.:)
     
  5. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #5

Share This Page