Infuriating new problem, webpages partially load.

Discussion in 'MacBook Pro' started by widderic, Sep 4, 2016.

  1. widderic macrumors newbie

    Joined:
    Mar 25, 2014
    #1
    So this will happen with Safari, Firefox, or Chrome.



    I'll load a page and it partially loads. For example if I go to a website where there are thumbnails for a list of videos, most of the thumbnails will appear to be black or have a question mark, like the page just gave up on loading... If I refresh, some of those thumbnails will show but then OTHERS will disappear, like it's having a hard time fetching information.



    So I tried disabling DNS pre fetching lol, no help there. I even replaced my DNS servers with some better ones thinking that comcast was just supplying me with lame DNS servers...



    I ran ClamX AV to check for a virus and found a couple of mackeeper files and I deleted those, but other than that I am at a complete loss. It's just frustrating that i can't figure it out at this point.



    Maybe I need to upgrade to El Capitan? I'm running the latest Yosemite version, but this problem has only developed over the last few days and I can't remember downloading anything too crazy.
     
  2. jerryk, Sep 4, 2016
    Last edited: Sep 4, 2016

    jerryk macrumors 68020

    Joined:
    Nov 3, 2011
    Location:
    SF Bay Area
    #2
    Is this just on one site. It does sound like a server problem. If this is a something like Pirate good luck.
     
  3. thats all folks macrumors 6502a

    thats all folks

    Joined:
    Dec 20, 2013
    Location:
    Austin (supposedly in Texas)
    #3
    have you tried from a location on a completely different network and source of internet? have you refreshed your browsers recently (cleared cookies, history, cache... and done a hard restart)?
     
  4. widderic thread starter macrumors newbie

    Joined:
    Mar 25, 2014
    #4
    I've done a hard restart and cleared the cache as well. I've tried using someone elses internet and still get the same problem. Phones and iPads load up sites just fine, so it seems to be localized to my Macbook Pro... :(
     
  5. poorcody macrumors 6502

    poorcody

    Joined:
    Jul 23, 2013
    #5
    Oh man I had that exact problem a few years ago... I never entirely figured out its source. It happened as soon as I upgraded to Mavericks, and only cleared-up after maybe eight months or so with one of the later Mavericks upgrades.

    I suspect it was some idiosyncratic interaction bug between the OS and my router. DNS was somehow the issue, and doing "prefetch" with the browser, switching DNS servers and such seemed to help but never solved it. What was revealing was that when I ran Windows under Parallels on the same machine, there was no similar problem. Yet it affected every browser under OS X. And it happened under both my Mac Mini and Mac Air, but not my iPhone or iPad.

    Anyway, I did stumble across a simple fix: the problem occurred when I used either ethernet or WiFi. But oddly, I found if I had both connected simultaneously, the problem seemed to go away. Made no sense but it worked. See if that helps...

    Otherwise I would recommend updating to El Captain -- I had the problem under early versions of Mavericks, but skipped Yosemite and never had a problem with El Captain.

    If neither of those works, I would recommend trying a new router of different brand. I don't think the router by itself was the problem, but some bug resulting from the OS-router combination I suspect was the problem.

    I wish you luck -- it was so unbelievably frustrating I almost dumped the Mac entirely!
     
  6. widderic, Sep 6, 2016
    Last edited: Sep 6, 2016

    widderic thread starter macrumors newbie

    Joined:
    Mar 25, 2014
    #6
    Your solidarity in my frustrations helps soothe my pain, thanks for the helpful information. I too suspected maybe something was going on with this router that comcast has supplied me with. I'm having a hard time locating a firmware update for it, and my technological expertise hits a brick wall when it comes to anything "internet" in terms of how it works and what kinds of software it runs on.

    In another thread I was asked to run a report, I will paste that here so that I can cross reference what I am told. I suppose I could also try flushing the cache through terminal, but I'm not sure what command I should use for El Capitan. (I upgraded and the problem still persists btw). And with that I can also delete the .plist file in my library. Hell maybe even starting a new location for my internet in network under preferences might help too. But yeah iphone and ipad are fine so you may be onto something with the OSX and router. How maddening that is!! Using the internet seems so primitive now with everything loading partially. Thanks agin.

    EtreCheck version: 3.0.3 (307)

    Report generated 2016-09-06 17:43:17

    Download EtreCheck from https://etrecheck.com

    Runtime 1:33

    Performance: Excellent



    Click the [Support] links for help with non-Apple products.

    Click the [Details] links for more information about that line.



    Problem: Other problem

    Description:

    Webpages are only partially loading. Question mark boxes instead of thumbnails, or thumbnails missing. Refreshing the page sometimes works but rarely.



    Hardware Information:

    MacBook Pro (Retina, 15-inch, Mid 2014)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    MacBook Pro - model: MacBookPro11,3

    1 2.8 GHz Intel Core i7 CPU: 4-core

    16 GB RAM Not upgradeable

    BANK 0/DIMM0

    8 GB DDR3 1600 MHz ok

    BANK 1/DIMM0

    8 GB DDR3 1600 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: en0: 802.11 a/b/g/n/ac

    Battery: Health = Normal - Cycle count = 350


    Video Information:

    Intel Iris Pro

    NVIDIA GeForce GT 750M - VRAM: 2048 MB

    Color LCD 2880 x 1800


    System Software:

    OS X El Capitan 10.11.6 (15G31) - Time since boot: less than an hour


    Disk Information:

    APPLE SSD SM1024F disk0 : (1 TB) (Solid State - TRIM: Yes)

    EFI (disk0s1) <not mounted> : 210 MB

    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB

    Macintosh HD (disk1) / : 999.35 GB (172.88 GB free)

    Encrypted AES-XTS Unlocked

    Core Storage: disk0s2 999.70 GB Online


    USB Information:

    Apple Inc. Apple Internal Keyboard / Trackpad

    Apple Inc. BRCM20702 Hub

    Apple Inc. Bluetooth USB Host Controller


    Thunderbolt Information:

    Apple Inc. thunderbolt_bus


    Configuration files:

    /etc/hosts - Count: 17


    Gatekeeper:

    Anywhere


    Kernel Extensions:

    /Applications/Toast 11 Titanium/Spin Doctor.app

    [not loaded] com.hzsystems.terminus.driver (4 - 2014-11-30) [Support]



    /Library/Extensions

    [loaded] at.obdev.nke.LittleSnitch (3.5.1 - SDK 10.8 - 2016-09-04) [Support]



    /System/Library/Extensions

    [loaded] com.LaCie.ScsiType00 (1.8.0 - SDK 10.5 - 2016-09-04) [Support]

    [loaded] com.nvidia.CUDA (1.1.0 - 2016-09-04) [Support]



    ~/Library/Services/ToastIt.service/Contents/MacOS

    [not loaded] com.roxio.TDIXController (2.0 - 2014-11-30) [Support]



    System Launch Agents:

    [not loaded] 6 Apple tasks

    [loaded] 161 Apple tasks

    [running] 71 Apple tasks


    System Launch Daemons:

    [not loaded] 47 Apple tasks

    [loaded] 159 Apple tasks

    [running] 84 Apple tasks


    Launch Agents:

    [not loaded] com.adobe.AAM.Updater-1.0.plist (2015-04-27) [Support]

    [running] com.adobe.AdobeCreativeCloud.plist (2015-04-26) [Support]

    [running] com.bjango.istatmenusagent.plist (2015-10-04) [Support]

    [running] com.bjango.istatmenusnotifications.plist (2015-10-04) [Support]

    [running] com.bjango.istatmenusstatus.plist (2015-10-04) [Support]

    [running] com.canon.MFManager.plist (2012-05-22) [Support]

    [loaded] com.google.keystone.agent.plist (2016-07-11) [Support]

    [running] com.lacie.LaCieDesktopManagerAgent.plist (2016-09-06) [Support]

    [loaded] com.nvidia.CUDASoftwareUpdate.plist (2016-09-06)


    Launch Daemons:

    [loaded] com.adobe.SwitchBoard.plist (2015-04-27) [Support]

    [running] com.adobe.adobeupdatedaemon.plist (2015-04-26) [Support]

    [loaded] com.adobe.fpsaud.plist (2016-06-28) [Support]

    [loaded] com.apple.aelwriter.plist (2014-12-07)

    [running] com.apple.qmaster.qmasterd.plist (2010-08-25)

    [running] com.bjango.istatmenusdaemon.plist (2015-10-04) [Support]

    [loaded] com.ea.origin.ESHelper.plist (2015-02-07) [Support]

    [loaded] com.google.keystone.daemon.plist (2016-09-01) [Support]

    [loaded] com.lacie.LaCieDesktopManagerDaemon.plist (2015-03-30) [Support]

    [loaded] com.macpaw.CleanMyMac3.Agent.plist (2015-10-17) [Support]

    [loaded] com.microsoft.office.licensing.helper.plist (2014-05-09) [Support]

    [loaded] com.nvidia.cuda.launcher.plist (2015-01-08) [Support]

    [loaded] uk.co.canimaansoftware.ClamXavHelper.plist (2016-09-03) [Support]

    [loaded] uk.co.canimaansoftware.ClamXavHelperUpdater.plist (2016-09-03) [Support]


    User Launch Agents:

    [loaded] com.adobe.AAM.Updater-1.0.plist (2015-01-08) [Support]

    [loaded] com.macpaw.CleanMyMac3.Scheduler.plist (2016-09-02)

    [loaded] uk.co.canimaansoftware.clamxav.UninstallWatcher.plist (2016-09-03)


    User Login Items:

    Dropbox Application (/Applications/Dropbox.app)

    CleanMyMac 3 Menu Application (/Applications/CleanMyMac 3.app/Contents/MacOS/CleanMyMac 3 Menu.app)

    Photo Stream URL SMLoginItem (/Applications/iPhoto.app/Contents/Library/LoginItems/PhotoStreamAgent.app)


    Internet Plug-ins:

    FlashPlayer-10.6: 22.0.0.209 - SDK 10.9 (2016-09-05) [Support]

    QuickTime Plugin: 7.7.3 (2016-07-08)

    Flash Player: 22.0.0.209 - SDK 10.9 (2016-09-05) [Support]

    Default Browser: 601 - SDK 10.11 (2016-07-08)

    o1dbrowserplugin: 5.41.3.0 - SDK 10.8 (2015-12-16) [Support]

    SharePointBrowserPlugin: 14.4.2 - SDK 10.6 (2016-04-18) [Support]

    PepperFlashPlayer: 22.0.0.209 - SDK 10.6 (2016-07-13) [Support]

    Unity Web Player: UnityPlayer version 4.6.2f1 - SDK 10.6 (2015-02-04) [Support]

    Silverlight: 5.1.40728.0 - SDK 10.6 (2016-01-17) [Support]

    MeetingJoinPlugin: Unknown - SDK 10.6 (2016-04-18) [Support]



    Audio Plug-ins:

    DVCPROHDAudio: 1.3.2 (2014-12-23)



    3rd Party Preference Panes:

    CUDA Preferences (2014-11-18) [Support]

    Flash Player (2016-06-28) [Support]

    Flip4Mac WMV (2014-05-12) [Support]


    Time Machine:

    Time Machine not configured!



    Top Processes by CPU:

    3% kernel_task

    3% WindowServer

    2% Safari

    2% hidd

    2% fontd


    Top Processes by Memory:

    1.01 GB kernel_task

    328 MB com.apple.WebKit.WebContent(3)

    180 MB mdworker(9)

    164 MB Dropbox

    147 MB Finder


    Virtual Memory Information:

    11.00 GB Free RAM

    4.99 GB Used RAM (2.00 GB Cached)

    0 B Swap Used


    Diagnostics Information:

    Sep 6, 2016, 05:39:16 PM Self test - passed

    --------------------------------------

    UPDATE: I uninstalled CleanMyMac and uninstalled every internet plug in as well us deselected allow internet plug ins on my safari browser. The problem still persists.
     
  7. MacGizmo, Sep 7, 2016
    Last edited: Sep 7, 2016

    MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #7
    Have you considered that the problem might be your router, and not the computer?
    [update: Oops. I see that you have. Sorry I missed that the first time]
     
  8. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #8
    That's what I'm thinking the computer isn't the issue, but the local network

    OP, have you tried this on a public wifi network, to see if the issue remains?
     
  9. poorcody, Sep 7, 2016
    Last edited: Sep 7, 2016

    poorcody macrumors 6502

    poorcody

    Joined:
    Jul 23, 2013
    #9
    Did you happen to try running Wifi and Ethernet simultaneously? (Maybe you don't have ethernet on the Mac.) I know it's probably not a solution if you need Wifi-only, but at least it would tell me if it's the same problem.

    You said you had the same issue when you took it to a friend's house... did they have the same Comcast router? Maybe you should go to McDonalds or Starbucks or whatever and try a different WiFi.

    Since you said you had an iPhone, can you tether to that to try it out? Then you could be sure to bypass both your router and Comcast.

    Also just to test the integrity of your internet connection, you may want to fire-up Terminal and do a "ping www.google.com". Let it run for a few minutes and make sure no packets are dropping. If you had a "noisy" internet line it might manifest itself that way.

    If you watch a video on YouTube, does it play without pauses? If so, then that would point to a DNS problem again.
     

Share This Page