Insane Text Message Lag???

Kurt Hustle

macrumors newbie
Original poster
Jul 16, 2007
17
0
Hey guys...I had made a post about a week back when one night I noticed my iPhone stopped receiving texts..this lasted about 12 hrs and when they finally started up again I received about 100 correctly timestamped messages. This slightly was making me angry as I primarily use texting, even more so then the phone feature.

Now the phone is starting to do it mult times a day. Sometimes ill get lucky and it will only lag for 15-30 mins, but most times it will last anywhere from 2-10 hours.

Has anyone else experienced something like this...this often? I swear its happened like at least 20 times now...I would generally assume its a network issue...but this many times? I cant imagine their service being that lousy..Also during the text lag times..I've had 2 people tell me that when calling me my phone it went straight to voicemail...while the phone was on..and I essentially was looking at it..waiting for their calls (not using any other features)

I'm at wits end ...and really looking for some help before I call ATT / Apple support. Anyone have any suggestions? I'm located in NYC if that has any bearing on the explanation.
 

djbahdow01

macrumors 6502a
Jan 19, 2004
568
0
Northeast, CT
Hey guys...I had made a post about a week back when one night I noticed my iPhone stopped receiving texts..this lasted about 12 hrs and when they finally started up again I received about 100 correctly timestamped messages. This slightly was making me angry as I primarily use texting, even more so then the phone feature.

Now the phone is starting to do it mult times a day. Sometimes ill get lucky and it will only lag for 15-30 mins, but most times it will last anywhere from 2-10 hours.

Has anyone else experienced something like this...this often? I swear its happened like at least 20 times now...I would generally assume its a network issue...but this many times? I cant imagine their service being that lousy..Also during the text lag times..I've had 2 people tell me that when calling me my phone it went straight to voicemail...while the phone was on..and I essentially was looking at it..waiting for their calls (not using any other features)

I'm at wits end ...and really looking for some help before I call ATT / Apple support. Anyone have any suggestions? I'm located in NYC if that has any bearing on the explanation.

I believe its an AT&T thing. When I text to Verizon customers and what not they don't receive it quickly. I received a text message from some one 12 hours after they sent it. I'm using a Moto Razr Black not an iPhone.
 

rdowns

macrumors Penryn
Jul 11, 2003
27,345
12,409
Saw your post last week and tested it. I'm in NYC too. Texts showed up with no lag. FWIW.
 

Kurt Hustle

macrumors newbie
Original poster
Jul 16, 2007
17
0
I believe its an AT&T thing. When I text to Verizon customers and what not they don't receive it quickly. I received a text message from some one 12 hours after they sent it. I'm using a Moto Razr Black not an iPhone.
I get what your saying..but my outgoing seems to work fine. It's not like a certain carrier's messages will get delayed. My incoming texts will outright stop working. I also have my aim im's forwarded to the phone...so I can test if my incoming texts are working by sending myself an IM on my home computer while they are being forwarded the the iPhone. I will unexpectedly stop receiving texts...then after X amount of time (like I said it varies..sometimes 15 mins...as long as 12 hrs) then all of a sudden the phone will start going nuts and I will receive a mass of incoming texts all correctly timestamped from when they were actually sent.
 

scaredpoet

macrumors 604
Apr 6, 2007
6,626
342
I'm getting no lag and am in the NYC metro area as well. Texts to Verizon, Sprint and AT&T users are sent and received in under a minute.
 

yotaguy

macrumors member
May 22, 2005
38
0
I dont have any lag.. This is more than likely a problem with ATT and their network..

I would call up ATT and ask if they can switch out the sim card. I had this issue awhile ago with an older phone and a new sim fixed the problem.
 

MarkMS

macrumors 6502a
Aug 30, 2006
991
0
No lag here as well. I've been with Cingular/AT&T now for about 5 years. They have really good service down here. Can't really be the iPhone, so yeah give AT&T a call.
 

chelsel

macrumors 6502
May 24, 2007
422
147
I get lag, but it's not the iPhone, just AT&T

I have this problem occasionally... it's not the iPhone from what I can tell, just the network (AT&T). I've experienced this problem on Treos and Cingular branded 8125s before.