Insanely slow boot

Discussion in 'OS X Mountain Lion (10.8)' started by Slapgravel, Jul 15, 2013.

  1. Slapgravel macrumors newbie

    Jul 15, 2013
    Hi guys,

    I have a MBP late 2009 OSX 10.8 upgraded to 8gb RAM. Once booted it runs like a dream. The problem however, is that it takes about 9-10 mins from pressing the power button to being able to open a program and get things working. I've disabled most of the startup programs (I think just dropbox is enabled) but no joy. I've done some digging and looked around the internet but there seems to be so many problems, I'm finding it hard to diagnose mine (as a slow boot is really the only symptom). I tried booting in verbose mode but I just don't know what I'm looking for there....was hoping to see an error or something, so it didn't help at all. I ran SU-mode and ran fsck -fy to which everything seemed fine. I've looked into defrag, but genuinely, even on windows, I never noticed a difference in performance, even when my drive was a nightmare. Also, from other threads....seems people feel strongly about defragging a mac so lets not go there :)

    Could anyone give me a hand in how to diagnose my problem so I can begin to repair it?
  2. Isamilis macrumors 6502a

    Apr 3, 2012
    Just quick steps:
    - have you try create another user and try login with that user?
    - some people found fresh install make system faster than upgrade, but this is last resort IMO
  3. Slapgravel thread starter macrumors newbie

    Jul 15, 2013
    A fresh user takes only a short amount of time less than my login. It really seems that the sluggish bit is before the login screen appears, although it's not very quick off of the mark once I do log in. 4:17 to get from the button to the login page > after I log in, it's 2:30 until I can make a browser display a web page.
  4. Fishrrman macrumors G5


    Feb 20, 2009
    How "full" is your hard drive?
    How much space remains free?

    It _is_ possible that the drive has become so fragmented that it's slowing down.

    What I would suggest:

    - Get ahold of an external drive
    - Use CarbonCopyCloner to do a full clone of your internal drive to the external backup
    - Boot from the backup
    - Use Disk Utility to erase the internal drive (yes), and then "re-clone" the backup drive back to the internal. During the re-clone process the files will be copied "contiguously", eliminating fragmentation and concentrating what free space there is "behind" the used portion of the drive.

    If that doesn't help, some thoughts:
    - Drive has hardware problems (replace drive)
    - OS has problems (re-install clean copy of OS)

    Something else you can try before doing anything more:
    If you have the option turned on to create a "sleep image", turn it OFF and delete the sleep image.
    To disable sleep image, enter this in terminal:
    sudo pmset hibernatemode 0
    (enter password when required)
    To remove the sleep image, enter this:
    sudo rm /var/vm/sleepimage

    I have a 2010 MBPro with the sleep image disable and the image file deleted. Runs fine without problems.
  5. Slapgravel thread starter macrumors newbie

    Jul 15, 2013
    I have about 60gb free on a 150gb HDD. I've disabled the sleep image before as someone else suggested it. Is there any way to actually see where the boot is having trouble? I'd really not want to reinstall atm unless it really was the only option.

    I was hoping it wouldn't come to a reinstall but I guess I have put a ton of crap on and off of this laptop. As I bought OSX 10.8 via an upgrade (from 10.6.8) from the appstore and hence have no physical copy. Can it be done? I've only ever reinstalled a windows comp before.

    Nevermind, I have google on another comp if I need it.

    I'll not be able to reinstall until I'm done with my thesis so I'll still be about for suggestions for a couple of months if anyone else has any.

    Thanks for your help thus far chaps.
  6. monkeybagel macrumors 65816

    Jul 24, 2011
    United States
    If you boot in Verbose mode you should be able to follow the readouts and see what stays on the screen an abnormally long time. It could be network related or service related. If you have virtualization software installed, they can add some time to the boot process to initialize their services (but not as long as you are noting).
  7. Slapgravel thread starter macrumors newbie

    Jul 15, 2013
    What would be an "abnormally long time" when verbose mode booting?

    How would I know if it was network / virtualisation related?
  8. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    Open System Prefs and in the Startup Disk panel make sure the correct disk is selected as the boot disk. If this is not correct the system will take longer to boot as it has to search all options (net boot etc) for a boot drive.

    Also you might try looking in console log right after a boot to see if that tips you off to anything.
  9. monkeybagel macrumors 65816

    Jul 24, 2011
    United States
    When you see the boot text flying up the screen, it pauses occasionally while the different kexts to initialize. Just watch the boot process and see if you see one at the bottom for 10+ seconds. Is the long delay during the verbose boot or after it goes into GUI mode and you see an arrow with your wallpaper and no finder?
  10. Fishrrman macrumors G5


    Feb 20, 2009
    "How would I know if it was network / virtualisation related?"

    1. Disconnect from the network
    2. Turn OFF any virtualization.
  11. Slapgravel thread starter macrumors newbie

    Jul 15, 2013
    To be fair it takes ages in verbose mode AND after the gui has initialised. Last boot took 4:25 from pressing the power button to opening the browser. I have checked the system.log and it does seem to hang on various things for a crazy amount of time (40 secs+) but it could just be that I'm not reading it right.

    <22/07/2013 08:57:11.266[1]: ( Unknown key for boolean: NSSupportsSuddenTermination>

    Seems to take 20+ secs for instance.

Share This Page