insert new HDD and then......

Discussion in 'MacBook Pro' started by ichi41, Oct 15, 2011.

  1. ichi41 macrumors newbie

    Joined:
    Oct 15, 2011
    #1
    hi every body
    i need an emergency help about my MBP (july 2009).
    the orginal HDD has been faild so i replace by a new Toshiba 640G. But system can't restore the back up or install fresh OSX (10.6).
    i format (Mac extended journaled) the hdd in other system(macbook) and use GUID kind. system can detect the hdd and show specificions but when i want to install the os x, at last step it errors that OS X can 't install on this computer, or when i want to restore at last step it says the disk can't be earsed.
    i use my orginal DVDs that came by laptop.

    hope TO any help
     
  2. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #2
    Are you using the discs that came with the machine? The grey ones?
     
  3. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #3
    THE orginal Grey disk

    Hi
    yes i use the orginal grey Dvds disks that came by MBP.
    the disk are not image or ilegal copy or ... they are orginal 10.6.
     
  4. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #4
    Any suggestion????????????????

    anybody hasn't any sugestion?
     
  5. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #5
    I don't understand the "other" system statement. If you are trying to install the disc while it is in another system using the install discs from the MBP it is going into, why not just place it into the MBP and format and install in that system, rather than using another system (if that is in fact what you are doing as that is what you wrote)? The discs will only work for the system they came with if you are trying to use it on another system (even though you are prepping it for the correct system it still won't work as the chipset will stop the install).
     
  6. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #6
    System Cannot format, SO

    hi squeakr
    thanks for reply
    the problem is:
    after the HDD was failed, i bought a new HDD (Toshiba 640G) and inserted in laptop, but the system cannot detect and format the new HDD, so i formated via USB2.0 as a external HDD (as mac extended JOURNALED format) in my friend's macbook. after that i inserted the formated new HDD in my own device and try to install a fresh OS X 10,6 with the orginal GREY dvd that came with MY MACBOOKPRO (mid 2009). but now laptop can detect new HDD but cannot install OS x and cannot restore my back up.
    what should i do now??????????????

    CU
     
  7. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #7
    Does your optical drive work? The fact you were able to install it on a different Mac makes me suspect your optical drive may not be working well.
     
  8. sehnsucht77 macrumors 6502

    Joined:
    Dec 26, 2008
    #8
    the normal installation scheme would be:
    -install new HDD
    -boot to disk in optical drive via restore CDs by pressing "c" during the reboot process
    -once the MB boots to the DVD, use Disk Utility (via customize option) to reformat the new disk by using journaled and reformat options
    -repeat the process and install the new option

    Since you can't boot to the new disk or install it tells me that you either have defective disks or a defective drive since it detect it but can't format the drive. a drive with a bad surface or bad sectors can't function well and you might have something like this...thoughts anyone?
     
  9. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #9
    hi sehnsucht77
    the reply is so helpfulllll but:

    i can boot by the GREY dvd and can go to Disk Utility or other places as you mentioned, but at last step to install OS X (when system estimate installation time remaining) it errors that " OS X can't install on this computer'' or when i want to restore back up at last step (when the disk is selected) it says " this disk can't be erased".
    OR as i remember when i inserted new HDD it can't detect or either format it.
    this problem could be related to new HDD?


    CU
     
  10. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #10
    install via USB 2.0

    i think that because of a bad surface on gery dvd, i can't install or restore (MYBE AS I THINK)
    So somebody knows how can i be able to install snowleopard 10.6 via USB 2,0?
    i can recall before installing lion on new loptops apple used USB 2.0 flashes insteade of grey Dvds to boot the devices in snowleopard. So would i need a bootable usb2,0 flash storge and a image of my own grey dvd?
     
  11. Naimfan macrumors 68040

    Naimfan

    Joined:
    Jan 15, 2003
    #11
    On your Macbook Pro, you can just use any Snow Leopard DVD - it doesn't have to be the gray one. So find or borrow a Snow Leopard retail DVD and use that.
     
  12. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #12
    problem, TO BE COUNTINUE

    hi
    i have the problem yet
    i change (correctly borrow from somebody) the mac OS X install dvd and used an external dvd ram, but i can't install or restore. at the frist it says it can only restore back up but so i try to restore that, it started to restore and at 5% it listed a lot of errors and cancelled the process, after that i think i should format again the HDD but :
    what is the POSIX error?
    when i want to format the HDD it says " POSIX error: can't allocate memory"
     
  13. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #13
    problem 2...........

    hi every one
    this is new side of the problem;
    this evening i inserted the new HDD into a HDD box (something that enable you to access the SATA HDD via USB2 or USB3) and used the old seagate HDD into MBP (it can enable me to trun on MBP and boot by DVD); after booting by mac os x install dvd and lunch the disk utility i could format (mac extended journaled) the new HDD as a external disk(this is strange , i CAN NOT able to format the HDD as an internal disk [POSIX error] but i CAN format it as an external disk, WHY????????????????), so inserted again the formated HDD into MBP and tried to install mac os x 10.6.
    every thing goes fine but at approximatly 50% it errors again: " the mac os x can't install on this computer. Call software manufacture"

    any sugestions???????????????
    hope to a help:confused:
     
  14. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #14
    exactly the same problem

    hi
    at macforum i found this:
    HDD doesn't function, but works as external
    Series of events:

    at "http://www.mac-forums.com/forums/apple-notebooks/254680-hdd-doesnt-function-but-works-external.html"

    " cactus331 (macforum member) says
    1. After bringing up my MacBook Pro from sleep, I couldn't save anything, so I rebooted.
    2. It wouldn't boot up, the computer just showed Apple logo.. I couldn't open in safe mode, but managed to load Recovery HD
    - when trying to repair or format the drive, I was getting "unmount error".
    3. I was told that my drive might be bad, so I bought a new one.
    4. After I installed Lion OS on the new disk, I put it inside.. and got the same problem as with the old drive.
    5. I have noticed that both drives work fine when connected as external via USB.

    Does anyone have any suggestions?
    Would buying a new hdd connector cable help?

    Thank you in advance."

    now i can restore the back up on old hdd via hdd box and now i 'm running mac on my MBP via usb 2.

    anybody any suggestions??????
     
  15. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #15
    IF your old drive is working externally and was not internally (and seems to be the same with your new drive), sounds like the cable has gone bad or the HDD controller could have gone bad as well, which might mean your logic board is failing. I would try and load AHT from the CD included with your MBP and see if it reveals any faults on the system.
     
  16. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #16
    Thanks GOD

    Hi Dear squeakr
    thanks god that some one answered me (thanks again squeakr):eek:
    squeakr i have the same idea but please explain more details about AHT and logic board and about last sentence:

    I would try and load AHT from the CD included with your MBP and see if it reveals any faults on the system.



    thanks
     
  17. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #17
    Aht

    hi squeakr
    i googled and found something related to AHT:
    Do you mean Apple Hardware Test as AHT?
    if yes, i have tested it 4 days ago and loaded without any errors.
    is there any other way to know?
     
  18. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #18
    Yes AHT is Apple Hardware Test. It is no the end all of tests, but a good indicator if something has failed. Since you recently ran it and found no errors, it seems to be reporting correctly. Was the hard drive installed when it ran (so it could test it as well)? It sounds like a cable issue if your drive is working intermittently and happening on both new and old drives (yet they work fine within the external enclosures). I would see about getting to an Apple store an see if they can run their tests. They have a test program that will test deeper than AHT can. Good luck with this issue. The only other idea I had as to why it might not for with the new drive is if a jumper setting on the drive was enabled, but then it had issues with the stock drive so I would tend to rule that out.
     
  19. ichi41 thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #19
    fundamental problem is

    hi squeakr
    Thanks again for your valuable replies ;)
    Fundamental problem is i haven't access to any Apple Store or either an authorized repair center in my country :(
    yesterday again as you said i tried AHD as normal and as Extended test, it didn't find any problem.
    And about the jumpers: i look carefully at new HDD, it hasn't any jumper and exactly look like the old one (i think the jumpers era had been finished many times ago), but thank again for the idea.
    Can it related to the cable; last week for only i could able to format and partition the old HDD(only that time i could format it), but restore process was failed AND for other attempts it says different errors:
    POSIX Error: Can't allocate memory
    POSIX Error: Resource is busy
     
  20. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #20
    With the other errors, it is sounding more and more like a logic board failing. The jumpers are still there and viable, it is just they are not a needed as much today as they were years ago with auto-configurations being so much more precise, so rarely do they include the actual jumper in the boxes with the newer ones (although the pins or at least the pads are still there if you look hard enough).
     

Share This Page