install bugzilla on macbook pro

Discussion in 'macOS' started by darakok, Dec 7, 2010.

  1. darakok, Dec 7, 2010
    Last edited: Dec 7, 2010

    darakok macrumors newbie

    Joined:
    Jul 21, 2010
    #1
    Dear mac users,

    I want to install bugzilla latest version on macbook pro. I've found one tutorial showing instruction on installing it on snow leopard of mac pro and macbook pro.

    I've problem during the installation of perl modules.

    Code:
    Warning (usually harmless): 'YAML' not installed, will not store persistent state
    
      CPAN.pm: Going to build L/LD/LDS/GD-2.45.tar.gz
    
    Notice: Type perl Makefile.PL -h for command-line option summary.
    
    **UNRECOVERABLE ERROR**
    Could not find gdlib-config in the search path. Please install libgd 2.0.28 or higher.
    If you want to try to compile anyway, please rerun this script with the option --ignore_missing_gd.
    Warning: No success on command[/usr/bin/perl Makefile.PL]
    Warning (usually harmless): 'YAML' not installed, will not store persistent state
      LDS/GD-2.45.tar.gz
      /usr/bin/perl Makefile.PL -- NOT OK
    Running make test
      Make had some problems, won't test
    Running make install
      Make had some problems, won't install
    Could not read '/Users/nouvsophat/.cpan/build/GD-2.45-jHGpmV/META.yml'. Falling back to other methods to determine prerequisites
    Failed during this command:
     LDS/GD-2.45.tar.gz                           : writemakefile NO '/usr/bin/perl Makefile.PL' returned status 512
    
    bugzilla on macbook pro with snow leopard on top: http://developerbits.blogspot.com/2...la-on-mac-pro-or-macbook.html#installCommands
    Can somebody here help me please?
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
  3. darakok thread starter macrumors newbie

    Joined:
    Jul 21, 2010
    #3
    Thanks.

    I download it and install manually. it works. But i had to spend times installing each different perl module only to find out that I need a a few more dependencies before I can install that particular module. It's really cumbersome.

    I know someone one the internet show a turtorial using CPAN. but it doesn't work in my case.
     

Share This Page