Install button does nothing.

ARF900

macrumors 65816
Original poster
Oct 30, 2009
1,119
0
Okay, so I'm on an iPhone 5, trying to download apps I already own, the install (or iclould) button does nothing. I can tap away at it and there is no response, the "press" animation plays but it doesnt actually do anything. It doesnt matter if I'm in the app page, search screen or purchased apps list, nothing.

I've tried restarting the app store and hard booting the phone. Nothing. Anybody else having this problem?

EDIT: Actually I can't download any apps, if I try getting a new one, the green download thing will pop up and it will ask for my password. Then, nothing.
 

HazyCloud

macrumors 68030
Jun 30, 2010
2,749
13
Try signing out of the App Store and back in. If it continues, take it to Apple and have a Genius look at it.
 

ARF900

macrumors 65816
Original poster
Oct 30, 2009
1,119
0
Try signing out of the App Store and back in. If it continues, take it to Apple and have a Genius look at it.
Did that, have tried hardbooting multiple more times. Still doesn't work. This freaking phone has nothing but problems :(
 

HazyCloud

macrumors 68030
Jun 30, 2010
2,749
13
Interesting. What about paid apps? Have you tried getting one of those? Have you tried installing an app from the 'Purchased' section?
 

ARF900

macrumors 65816
Original poster
Oct 30, 2009
1,119
0
Interesting. What about paid apps? Have you tried getting one of those? Have you tried installing an app from the 'Purchased' section?
Yep, not a single thing works. I got the phone 3 days ago and it was fine until this morning, then just decided it didnt want to do it anymore. Guess ill have to wipe it and restore from backup, thankfully I just made one last night.
 

HazyCloud

macrumors 68030
Jun 30, 2010
2,749
13
Yep, that's what I was going to suggest if that didn't work. Of course your next option is taking it to Apple.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.