install free apps on 1.14?

Discussion in 'iPod touch Hacks' started by citivolus, Sep 19, 2008.

  1. citivolus macrumors 6502a

    Joined:
    Sep 19, 2008
    #1
    I downgraded back to 1.14 since I felt that my battery life was significantly reduced on 2.0. However I lost the one app I installed, the NY Times Reader (free app). Is there any way to get this to run on 1.14?
     
  2. Claytybob macrumors member

    Claytybob

    Joined:
    Jul 9, 2008
    Location:
    Kokomo, Indiana, USA
    #2
    Not that I believe unless you have the *.xcodeproj (etc.) Files to change the source to use classic methods, the iPhone Developing Scene has changed immensely since the SDK...Including the way developers code.
     
  3. citivolus thread starter macrumors 6502a

    Joined:
    Sep 19, 2008
    #3
    So does this mean that all 3rd party apps were written using an SDK that only works on firmware > 2.0?
     
  4. Claytybob macrumors member

    Claytybob

    Joined:
    Jul 9, 2008
    Location:
    Kokomo, Indiana, USA
    #4
    I'm sorry to say but yes. This is because the 2.0 software has some classes that 1.x does not. One is "touch" which almost all 2.0 apps use. Before 2.0 all developers had to use "click" and in 2.0 apple thought about it and decided that "touch" was a better name for the class. Anyways, there are a lot of small things like that which makes them incompatible!
     

Share This Page