Install pages on JB iOS 5.0.1

Discussion in 'Jailbreaks and iOS Hacks' started by kimlo, Apr 1, 2012.

  1. kimlo macrumors member

    Joined:
    Jun 7, 2010
    #1
    I did a quick search and couldn't find anything relevant to this.

    When I try to install Pages from the App Store I get a "This app requires iOS 5.1".

    So is there any Cydia tweak that will work around this?

    The only thing I can think of is to "pirate" one of the previous versions of the app that is compatible(or maybe even pirate the latest version, perhaps the 5.1 requirement is artificial)?

    I absolutely hate not buying apps as it's so much easier to get them on all my iOS devices, update them in future and so on by buying them, but if piracy is the ONLY option to get Pages then that's what I'll do because I really need it, but it's not worth losing my JB over.

    I also don't want to buy any of the alternate word processors on the App Store - only want the Apple Stuff.

    Any tips would be appreciated :)
     
  2. Mrarkon macrumors newbie

    Joined:
    Apr 1, 2012
    Location:
    New Jersey, USA
    #2
    Edit the SystemVersion.plist file via iFile to show iOS 5.1 as installed. Install it from the App Store after that, it should work fine.
    The file is located in the “/System/Library/CoreServices/” folder.
     
  3. srgz macrumors member

    Joined:
    Aug 22, 2010
    #3
    Just wanted to say thank you to Markon for this.
    This is a great workaround -- I'm on an iPad 1 and have had 5.0.1 untethered JB's -- and alot of apps that I purchased are telling me that I have to upgrade to 5.1.1 for them to be able to upgrade to the latest version. BS! I edited the version plist file and oh magically the apps install and run just fine. I hate forced upgrades. OK Rant over thanks for fix :D
    The FiOS Streaming TV app works great I might add; and every asingle pp that has this "requirement" of 5.1.1 that I have found runs perfectly fine on JB'd 5.0.1 with modified version PLIST. So it is in fact a fake requirement and there's nothing special about 5.1.1 that these apps need to run.
     

Share This Page