Install software Issues ... missing "init.csh"

Discussion in 'Mac Basics and Help' started by EMKoper, Nov 7, 2005.

  1. EMKoper macrumors regular


    Dec 18, 2002
    Stafford, VA
    Hello - I have had trouble installing Canon printer software and Adobe Acrobat Reader 7.0 lately for the same problem. Both would stop during install and the logs point to an issure with the file "/sw/bin/init.csh" ...

    Installing as the root user worked in both cases, but I would like to track down this problem ... I can't even find a folder "sw" on my harddrive. Here is a part of the Acrobat Reader log:

    Nov 7 08:55:38 PowerMac : postflight[651]: csh: /sw/bin/init.csh: No such file or directory.
    Nov 7 08:55:38 PowerMac : postflight[651]:
    Nov 7 08:55:38 PowerMac : Install failed: The following install step failed: run postflight script for Adobe Reader Download Manager

    System is OSX 10.4 and the PM listed in my signature. Any ideas?
  2. robbieduncan Moderator emeritus


    Jul 24, 2002
    /sw tends to mean that fink (a nifty way to get and compile Unix tools and apps) is installed. Cannon should not require that!
  3. EMKoper thread starter macrumors regular


    Dec 18, 2002
    Stafford, VA
    Still No Luck ...

    * Bump *

    Still looking for a fix ... I've tried installing other things recently and the Canon software and Acrobat reader seems to be the only two problem children. Any Unix savvy folks out there that might have any ideas?
  4. thewayfaerer macrumors newbie


    May 14, 2008
    Solution! (I hope)

    I think this is no problem of the Canon Installer. I had the same problem and it was because this sw/bin/init.csh path was in the .cshrc file in my user directory. This file is invoked by the install script and this leads to the missing file. In my case, I think it was a deleted fink installation.

    I think it is save to delete this file, because an initial mac os installation does not have it. To do so, do the following:

    - Start a terminal window
    - You should be in your home directory (your name at the prompt), otherwise type "cd $HOME"
    - You can look into this file with "more .cshrc"
    - Delete it with "rm .cshrc". You can also rename it with "mv .cshrc .cshrc_old"

    Now the installer should work.
    If you don't have this file, then you have a different problem but I think it has to be something similar.

    Hope this helps!

Share This Page