Install to thumb drive, now can't load from hd

Discussion in 'OS X Yosemite (10.10)' started by Motoxmann, Aug 2, 2014.

  1. Motoxmann macrumors member

    Joined:
    Apr 17, 2010
    #1
    I really hope i didn't screw something up here. I downloaded the beta to my main HD of my imac and when I ran the setup I chose to install it to a USB 3.0 thumb drive. The computer restarted and went to the install process via "osx installer". Somewhere it messed up and says that the install failed. After a couple of attempts I just tried to boot back into the main HD (by holding down option at restart and choosing Mac HD) but when it starts to load it goes to the osx install screen for Yosemite. I can't get my main HD to load. If I go to disk utility in the osx installer I can see the "Mac HD" and it shows 2.92 tb total disk space with 500 gig being used which is correct but how can I get it to load? I'm praying that I didn't somehow wipe the main HD. I don't know I could have since I chose install to "flash drive" (what I named the thumb drive) at setup. Any help is much appreciated. Thanks
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Did you try going back into the recovery partition? See if you can recover OS X from there.

    Hopefully you have a backup of data.
     
  3. Motoxmann thread starter macrumors member

    Joined:
    Apr 17, 2010
    #3
    No back up unfortunately which is why I'm a little stressed at this point. I thought that that selecting to install it to the thumb drive would only affect said thumb drive

    So when I turn on the imac it tries to install Yosemite. If I go to disk utility I have:

    Macintosh HD
    Macintosh HD (2.92 tb capacity, 439.1 gb used)
    disk1s4 (134.2 mb capacity) not sure what this is
    Bootcamp (200 gb capacity, 140 used)

    disk3
    OS X install ESD (5.24 gb capacity, 5.17 used) calls it an OS X install DVD
    disk4
    OS X base system (1.29 gb capacity, 1.26 used)


    This is with the thumb drive unplugged and the SuperDrive isn't even hooked up so no DVD. Since the file for the Yosemite beta downloaded to the Mac HD drive is it directly booting to "disk3" treating it as a boot up disk? If I erase that disk will it then revert to booting from the Macintosh HD?

    The fact that the "Macintosh HD" shows 439 gb used tells me that the data is still there, I just don't know how to get to it. I also don't know what I'm talking about which is why I come to you fine people.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Just follow this guide to reselect the Mavs partition as the startup volume and you will be fine.
     
  5. abcdefg12345 macrumors 6502

    abcdefg12345

    Joined:
    Jul 10, 2013
    #5
    happened to me when i installed Yosemite DP1 on an external hdd

    heres what i did

    booted to recovery and chose startup disk and selected my mavericks hd and it started normally
     
  6. Motoxmann, Aug 2, 2014
    Last edited: Aug 2, 2014

    Motoxmann thread starter macrumors member

    Joined:
    Apr 17, 2010
    #6
    Thanks for the replies. When I boot into recovery mode, in stead of having the Mac HD and Yosemite icons, as it has in the picture of the guide, all I have is Mac HD 10.9.4 and bootcamp. When I select 10.9.4 as the startup disk and restart it goes straight into the installer again.

    Yosemite never fully installed. It kept saying that it couldn't install for some reason.
     
  7. Motoxmann thread starter macrumors member

    Joined:
    Apr 17, 2010
    #7
    got it working. I just tried reinstalling Yosemite on the flash drive. Took 4 or 5 more tries but it finally installed. I thin that what happened was that once the installer installed 10.10 on the drive it deleted itself, so it was no longer trying to boot into the install process. Once i restarted from Yosemite and held down option to choose where i wanted to boot, it booted into Mavericks just fine. Crises averted. Proper back up setup incoming ASAP.

    Yosemite runs super slow on the 3.0 flash drive, but at least i can get into my main drive now. Thanks for the replies!
     

Share This Page