Install Turkish Language w/o Disc

Discussion in 'macOS' started by mr.steevo, Jun 10, 2010.

  1. mr.steevo macrumors 65816

    mr.steevo

    Joined:
    Jul 21, 2004
    #1
    Hi,

    I'm in Turkey visiting my wife's grandmother. We intend to leave her the PowerBook 1.67 but the OS is all in English as I didn't install other languages to save space. I also have the habit of running Monolingual to remove any trace of other languages. Of course I don't have the copy of 10.5 with me and OS X is unheard of in the small town we are in.

    Is there anyway to download the Turkish language extensions/localizations from somewhere. It would be a big help if someone could share a solution.

    s.
     
  2. larkost macrumors 6502a

    Joined:
    Oct 13, 2007
    #2
    I have good news, and bad news for you: the good news is that not having your install DVD is not going to make a difference in this. The bad news is that it is not going to make a difference because MacOS X does not have a Turkish localization to begin with. So no matter what you are not going to get Apple-provided tools and apps to display Turkish menus.

    That being said, you should still be able to do two things:

    1) In the "Language and Text" control panel you should still be able to "Edit List..." and put the Turkish language at the top of the list, so any apps that do have Turkish localizations will choose those (not betting too much here).

    2) Also in the same control panel you can switch over things in the Fomats, and enable the Turkish keyboard (if you have one to use).
     
  3. mr.steevo thread starter macrumors 65816

    mr.steevo

    Joined:
    Jul 21, 2004
    #3
    Hi,

    That is good news (and bad). Thanks for letting me know that Turkish isn't even an option. I wasn't sure if it was as I don't have the disc but I did notice Turkish language options in System Preferences. Safari and Onyx show Turkish, but other than that...

    Hey, at least I now know that there is nothing more I can do.

    Thank you.

    s.
     
  4. mrchinchilla macrumors 6502

    mrchinchilla

    Joined:
    Mar 6, 2009
    #4
    You might as well give it a try – go into the International, I think it's called that on Leopard, (or Language and Text) panel in System Preferences and it should be the first tab. Click "Edit List..." and enable "Türkçe" (but I'm sure you know it's that anyway) and drag it to the top of the list, making it the default language. Then reboot and see what happens.
     

Share This Page