Install Windows 7 on bootcamp through VMware fusion

Discussion in 'iMac' started by nikheradia, Dec 28, 2012.

  1. nikheradia macrumors newbie

    Dec 28, 2012
    I bought my imac almost 2 years back and now it's superdrive is broken...
    I need help installing windows on bootcamp...I've tried several methods through a USB but failed...when I followed all the instructions from this blog

    Everything worked well upto the point when I had to shut down vmware and reboot using refit which I did successfully too...but then windows opened and the last part of the setup was completing, then it restarted again. Again the refit showed up, I selected windows, the logo came and then the screen went blank....I waited for quite sometime hoping something would show up but unfortunately nothing happened...the screen was stuck on the black screen ...since I was so close to installing it, I just hope there's a solution for this problem...plz help me..
  2. sorlaker macrumors newbie

    Mar 3, 2013
    Hi! I've got the same situation as you. I've only tried to install windows 7 by usb and usb dvd drive so far. I think that Andrews tutorial won't work on out computer cause it's not using Lion (but it's just a thought). I'll try to install to install it here. Then i'll report it here.
  3. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    Why do people make this more complicated than it should be, or am I misunderstanding.
    Why do you install windows on another partition (Bootcamp) with VMware:confused:

    You don't even need bootcamp to do this, it's as simple as resizing (Partitioning) the HD with Disk Utility (From boot disk-Yes it works) and then Holding Option on start up and select the USB disk on which Windows Installer resides, it will boot and Install, you only have to format the Partition to NTFS and there it goes.
    Even for downloading Bootcamp Drivers you don't need Bootcamp Assistant!
  4. sorlaker macrumors newbie

    Mar 3, 2013
    Dude, the problem is that imac can only recognize it's superdrive. Any other kind of boot (usb or external cd drive) It says "No bootable device founded". And our superdrive cd is broken... so..
  5. forty2j macrumors 68030


    Jul 11, 2008
    I had this (except for the part where SuperDrive is broken; instead there simply isn't any). Turns out it matters which USB port your thumb drive is in. If you set up the thumb drive properly, stick it in slot 1, and boot holding down option, you should see it.

Share This Page