Installation of Linux on Macpro6,1 (6-core)

Discussion in 'Windows, Linux & Others on the Mac' started by gavinb, Apr 24, 2014.

  1. gavinb macrumors newbie

    Joined:
    Apr 24, 2014
    #1
    Has anybody been able to successfully install Linux (Ubuntu 12.04/14.04/Kubuntu 14.04/Kwheezy 1.5) on the MacPro6,1

    Mac Pro EFI Firmware Update 2.0 was applied....

    I prefer Debian 7.4 based Kwheezy to Ubuntu but it has no EFI boot loader.

    Only K/Ubuntu 12.04/14.04 that I have tried has EFI boot loaders. Bootup seems unsuccessful although possible in BOOTCAMP/Fusion. Raw disk access but VM powers off once attempting to write to BOOTCAMP volume.

    Tried amongst others Supergrub2 EFI bootdisk / Refit / Refind boot-loaders but no luck.

    Installation to USB completes but no way to bootup afterwards as only EFI boot loader from FAT/NTFS/HFS seems to be possible.

    Thoughts were to try Target Disk Mode from iMac but do have thunderbolt2thunderbolt cable to try.

    Anybody?
     
  2. gavinb thread starter macrumors newbie

    Joined:
    Apr 24, 2014
    #2
    Ubuntu 12.04.4 / ubuntu-12.04.4-alternate-amd64.iso installed successfully via Fusion on BOOTCAMP partition.

    Only boots up completely via Fusion, fails and reboots on physical boot-up.

    When Fusion message about allowing writes to /dev/disk0 came up I denied the writes although they still seemed to stick in the fusion session.

    One has to also keep the Volume name and Partition type to BOOTCAMP and 0700 so that Fusion will not complain that disk is inconsistent with VMDK upon boot up. (cgdisk)

    EFI bootloader was also added to a ubuntu folder containing grubx64.efi and shiimx64.efi with grub.cfg.
     
  3. andyrugbyref macrumors member

    Joined:
    Dec 27, 2012
    #3
    Do you want to run it via fusion?

    If not, install refit on you OSX partition.
    Manually create a 2nd partition.
    Install to that partition natively and then reboot using refit/grub.
     
  4. gavinb thread starter macrumors newbie

    Joined:
    Apr 24, 2014
    #4
    I wish to run Linux natively. It only boots up successfully via fusion.

    I have done many previous installs on other Mac hardware using refit and refind, with the MacPro 6,1 it proves to be virtually impossible.

    The boot up seems to fails because of video mode having a monitor attached to both a thunderbolt port and the HDMI port.
     

Share This Page