Installation problem on late 2008 MacBook Pro

Discussion in 'OS X Mavericks (10.9)' started by misnomer, Oct 22, 2013.

  1. misnomer macrumors newbie

    Joined:
    Oct 22, 2013
    #1
    Hi all,

    Longtime reader, first time poster. If this issue has already been addressed, I either couldn't find it or couldn't understand it. Any help would be greatly appreciated.

    I attempted to install 10.9 on my late 2008 MacBook Pro, which was running 10.8.5 at the time. After successfully downloading Mavericks, everything went smoothly up until restart.

    On restart was greeted with this:

    ____________________

    panic(cpu 8 caller 8xffffff881ab5e845): "Process 1 exec of /sbln/launchd failed, errno 2"@/SourceCache/xnu/xnu-2050.48.12/bsd/kern/kern_exec.c:3560
    Debugger called: <panic>
    Backtrace (CPU 8). Frame : Return Address
    ***[omitted]***

    BSD process name corresponding to current thread: init
    Boot args: config="\OS X Install Data\com.apple.Boot"

    Mac OS version:
    Not yet set

    Kernel version:
    Darwin Kernel Version 12.5.8: Sun Sep 29 13:33:47 PDT 2013; root:xnu-2050.48.12~1/RELEASE_X86_64
    Kernel UUID: ***[omitted]***
    Kernel alide: ***[omitted]***
    Kernel text base: ***[omitted]***
    System model name: ***[omitted]***

    System uptime in nanoseconds: ***[omitted]***
    ____________________
    :confused:
     
  2. mykelala01 macrumors 6502

    mykelala01

    Joined:
    May 17, 2009
    #2
    I also have a late 2008 macbook pro. It is running mountain Lion flawlessly... That is why I am afraid to instal Mavericks on it. When stuff like this happen, looks like you have a kernel panic. My applecare runs out last year. So I can't take it to apple store. Unless I talk to one of their customer relation and convince them to honor my problem. Let me know how you solve your problem. Have you tried clean instal?

    In the meantime let me instal this on my 2012 macbook pro...
     
  3. misnomer thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #3
    I haven't tried a clean install. I ran into a similar problem when I upgraded to Snow Leopard, but managed to fix it using a solution posted here. Hindsight being 20/20, I probably should have waited to upgrade. Hopefully someone can suggest a straightforward fix!

    Good luck!
     
  4. misnomer thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #5
    Thanks for replying. Just a couple of questions (I'm not an expert, so bear with me).

    1. Which mode: single-user or verbose?
    2. Once started in one of the above modes, does the troubleshooting proceed automatically? Further steps?

    Once again, thank you for taking the time to respond.

     
  5. misnomer thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #6
    Resolved (clean install)

    Just wanted to follow up with how I managed resolve the problem. This is probably basic stuff for most, but might prove helpful for others.

    1. Used disk utility to repair disk, which allowed me to start in Mountain Lion as before.
    http://support.apple.com/kb/TS1417

    2. Opted for a clean install of Mavericks after reading this:
    http://www.macworld.com/article/2056563/should-you-do-a-clean-install-of-mavericks.html

    3. Backed up data I wanted to save.

    4. Created a bootable Mavericks install drive using method 2 (Disk Utility)
    http://www.macworld.com/article/2056561/how-to-make-a-bootable-mavericks-install-drive.html

    5. Successfully installed.

    After the general steps outlined above, my computer runs better than it has in some time. Probably a combination of a clean drive and the performance improvements found in Mavericks.

    One exception: when I attempted to set up Find My Mac, I couldn't because my recovery partition had absconded on me. I'm in the process of creating that now: http://musings.silvertooth.us/2013/10/recovery-partition-creator-3-7-updated-for-mavericks/
     
  6. misnomer thread starter macrumors newbie

    Joined:
    Oct 22, 2013
    #7
  7. Dan04MCS macrumors member

    Joined:
    Sep 28, 2008
    #8
    I did a clean install on my 2008 Mac Pro and it's working great.

    2 cpu, ati 5770, 8gb mem, ssd drives.
     

Share This Page