iPhone Installed but no icon!

Discussion in 'Jailbreaks and iOS Hacks' started by Pilotpenguin, Mar 26, 2014.

  1. Pilotpenguin macrumors newbie

    Joined:
    Mar 26, 2014
    #1
    Hello

    Ive been using an app on my iphone 5S called SMSninja (iOS 7.06) for about a month now and for some reason it's just disappeared today. By this I mean the icon has gone and I can't access the app.

    Cydia shows the app as being installed though, and as part of my trouble shooting I've reinstalled and removed the app, and then reset my phone several times but the icon for the app just isn't there.

    Any suggestions here? I don't get why it's just disappeared and I also don't get why it's showing as being installed when it certainly isn't there on my phone

    Any input is appreciated
     
  2. AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #2
    do you have gridlock installed
     
  3. 0xyMoron macrumors 6502

    Joined:
    Oct 5, 2012
    Location:
    California
    #3
    Respring and it should show up again. (Even if you don't have Gridlock installed) Gridlock is known to make icons disappear if you move them.
     
  4. Pilotpenguin thread starter macrumors newbie

    Joined:
    Mar 26, 2014
    #4
    Hi

    No, gridlock is not installed. Respringing hasn't worked either
     
  5. AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #5
    Hard reset pressing home and sleep at same time until apple logo appears...try that
     
  6. Menneisyys2 macrumors 603

    Joined:
    Jun 7, 2011
    #6
  7. fdjofre macrumors member

    Joined:
    Oct 10, 2013
    #7
    Try finding it through spotlight. If it's there it's installed and working, you can even access it through there if you want. I do that for when I need to open up jb apps which I've hidden from SB. Also, check if some other tweak is hiding icons.
     
  8. Pilotpenguin thread starter macrumors newbie

    Joined:
    Mar 26, 2014
    #8
    I installed spotlight but no icon appeared for both spotlight and the app I'm having issues with.

    I've reset the phone several times, resprung it using some various apps and what's most baffling is that I hadn't installed anything or changed any setting before this issue began.

    I'm at a complete loss here
     
  9. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #9
    try running "uicache" in mobileterminal. technically should do the exact same as what Menneisyys2 does but it might help

    @Menneisyys2: am i correct in assuming that your app includes doing the same thing as running "uicache" in terminal?
     
  10. Menneisyys2 macrumors 603

    Joined:
    Jun 7, 2011
    #10
    Exactly. See my description in the linked-to thread.
     
  11. akuma13 macrumors 6502a

    akuma13

    Joined:
    Jan 10, 2006
    #11
    Something really strange just happened to me. Both iFile and Bytafont 2 icons just disappeared. I know the programs are there because Cydia says it's installed. Also a spotlight search brings up nothing.

    The only tinkering i did before was removing app data and uninstalling from the settings/general/usage menu. (There was a few ghost icons after deleting the apps i wanted to delete). I restarted the phone and the apps with ghost icons disappeared.
     
  12. Pilotpenguin thread starter macrumors newbie

    Joined:
    Mar 26, 2014
    #12
    Perhaps something is happening in iOS 7.06 jailbreak as your issue is exactly the same as mine? I have given up on smsninja now and I'm using an alternative app instead which installs and displays an icon
     
  13. akuma13 macrumors 6502a

    akuma13

    Joined:
    Jan 10, 2006
    #13
    Ok i got my icons back. All I did was reinstall the apps from Cydia and respringed.
     
  14. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #14
    Didn't you say you tried reinstalling the apps from cydia already in your opening post?
     
  15. Pilotpenguin thread starter macrumors newbie

    Joined:
    Mar 26, 2014
  16. akuma13 macrumors 6502a

    akuma13

    Joined:
    Jan 10, 2006
    #16
    I think you are talking about someone else. The Cydia apps I had problems with (the ones with the disappearing icons) I just reinstalled. I resprung and now everything shows up.
     
  17. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #17
    oh yes, my bad. I thought you were the thread starter
     

Share This Page