Installed Lion Cannot log in

Discussion in 'Mac OS X Lion (10.7)' started by Ratatapa, Jul 20, 2011.

  1. Ratatapa macrumors 6502a

    Joined:
    Apr 3, 2011
    #1
    Just installed Lion from the App store on my Imac 2010

    Upgraded from SL.

    Installation went find and i'm happy

    But when it rebooted it went at the login screen but all I see is the Apple Logo

    I cannot find my user account from SL

    What do I do?

    I have the buttons reboot shutdown etc but can't log in
     
  2. elbacko macrumors newbie

    Joined:
    Jul 20, 2011
    #2
    same problem.

    i have the same problem. have you found a solution so far?
     
  3. Mikeimr macrumors newbie

    Joined:
    Jul 20, 2011
    #3
    Can't login to lion

    Me too. On phone with support.. They are miffed
     
  4. Ratatapa thread starter macrumors 6502a

    Joined:
    Apr 3, 2011
    #4
    I got the answer here

    Ok step 1

    Boot your mac with Option + R holding it will boot into recovery mode
    Step 2 go into disk util and take terminal

    write resetpassword

    Choose root and put a password to log on root

    Reboot the mac and log in as root and root password that you've done

    Go in System Preference then users and group

    Create a new account with the SAME NAME and SAME PASSWORD as your old account and put it as an administrator


    When you accept it will say that in MacHD you already have an account with the same name do you want to use THAT folder

    You say YES it will take 3 mnutes about.

    Then log off and your account will be there, select it and put the password

    It will log and all your files will be there.

    That is what i done and it worked, my desktop docs and itunes is all there

    And for the time i took

    They refunded my Lion purchase and will send me a 50$ itunes store card :p

    Gotta love it hehe


    Sorry for the bad english :D
     
  5. Mikeimr macrumors newbie

    Joined:
    Jul 20, 2011
    #5
    Solution

    Go into recovery mode (command r at boot) open terminal. Type resetpassword reset the password for root. Reboot and login as root. Go to user account setup your user account (username needs to match your folder name under users - link them and reboot.
     
  6. Ratatapa thread starter macrumors 6502a

    Joined:
    Apr 3, 2011
    #6
    Yeah anyway it worked and got free lion so heh
     
  7. elbacko macrumors newbie

    Joined:
    Jul 20, 2011
    #7
    Thx!!!!

    thx dude. you saved my day. finally got it working :D :apple:
     
  8. clubber1966 macrumors newbie

    Joined:
    Aug 18, 2009
    #8
    Did not work for me

    I changed the root password but still cannot login as root?

    Stuck, no option but to go backwards and use a different method to get to lion!

    Not impressed so far.
     
  9. inkxel macrumors newbie

    Joined:
    Jul 20, 2011
    Location:
    Los Angeles
    #9
    removing applesetupdone

    another work around to re-enabling your users:

    this method works if you have already created a root user but forgot the password or if you just don't want to enable root. (I do suggest always creating a root user but not using it unless you know what youre doing. Creating the root user keeps other people from enabling root and gaining access if your computer is ever stolen)



    1. Boot the machine holding Command+R and open terminal. Once in single user mode, check the filesystem and mount the hard drive. (checking the file system and mounting the hard drive may not be necessary, I don't have lion installed to verify that step. this entire method can also be done by booting to single user mode by holding Command+S durring boot for which these directions were originally written)
    in terminal type:

    fsck -y

    mount -uaw /

    2. All we need to do now is remove a flag file from the system

    rm -rf /var/db/.AppleSetupDone

    3. Now reboot


    .AppleSetupDone is a flag created by the operating system when the system is first installed and your first user is created. removing this flag will force the computer to go back through the mac setup.

    from here the instructions are the same as the previous writers, you can at this point create a new user with a new name as admin and follow the previous users steps or you can enter the user name and password EXACTLY as you had them before installing Lion, when it prompts you and asks if you want to use the existing folder make sure you choose yes.
    that should do it.
     
  10. luxuryluke macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    Seattle, WA
    #10
    Login Failure

    • Have tried deleting the AppleSetupDone file, worked, setup new user, but still can't login to Lion

    • Have tried the Lion Recovery reset password tool, worked, but still can't login to Lion

    • Have tried the single user mode login and password reset using "launchctl load …", didn't work, it said that "com.apple.DirectoryServices.plist" is not available to load, so this didn't work for me

    • Have tried reinstalling Lion, but this obviously didn't work for me. :mad:

    I fear I may have more problems going on than others that have encountered the "Can't login after installing Lion" problem.

    Any ideas would be helpful.
     
  11. grantmcf macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    McKinney, TX
    #11
    I tried this but no joy

    I'm suffering from this problem too. Right now I have a rather large iMac paper weight on my desk.

    Option+R during reboot just takes me to Lion login as usual <shrug>. Holding down just the Option key gives me a choice of partitions ... "MacIntosh HD" or "Recovery". I chose "Recovery".

    I spent a few mins poking around in "Disk Utilities" looking for a "terminal" option. There was none. Finally found it outside of "Disk Utilities" at the main screen under "Utilities->Terminal" and gave the "resetpassword" command ...

    bash-3.2# resetpassword
    bash-3.2#

    I wasn't presented with any option to choose "root" or anything at all even.

    Any suggestions on how to proceed !?
     
  12. luxuryluke, Jul 21, 2011
    Last edited: Jul 21, 2011

    luxuryluke macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    Seattle, WA
    #12
    Installed on external

    Still no.

    Step 428:

    Installed Lion on a brand new external USB drive and am having the same no login results whether I put full user data during initial login or no data except username/pass on initial login.
    No worky.

    Since this is a MacBook Air you can imagine my anger at little recourse in booting from a CD/DVD.
    Calling Apple tomorrow morning bright and early.
     
  13. luxuryluke macrumors newbie

    Joined:
    Jul 21, 2011
    Location:
    Seattle, WA
    #13
    Still no luck

    Attempted install of Snow Leopard onto my MacBook Air via shared DVD over wifi on top of my locked Lion.
    No luck: kernel failed to load.

    One thing that surprised me about the Lion new user setup method was that Lion new user setup doesn't allow hyphenated short names. Essential to doing the user name restore method that some have succeeded with. With a short username of Luke-D, said method wouldn't work.

    Am in Lion Recovery Disk Utility and Restoring MBA volume onto a connected USB Drive, then wiping my internal drive to start over with a fresh Snow Leopard.

    Well see how that goes…
     
  14. jaredpotts macrumors newbie

    Joined:
    Feb 14, 2012
    #14
    Worked... Can't Login to Lion... Guest User...

    I have had this issue after installing last week.

    My HD looked as though it was read-only and all that it showed in a login window was "Guest User"

    Talked with Mac support for a while and ran different Single user prompts fsck, etc. and also in Recovery Mode through Terminal, resetpassword, diskutil, etc. still to no avail. Then tried partitioning the drive (which failed), and re-installing Lion (which also failed). Tried to log in on my old Leopard DVD but it didn't change anything. Also tried set up a new user, which it went back to the system beginning, but still did not show the log in screen. Still only showing Guest User.

    Doing all of the above I was still unable to change anything. and was going to resort to retrieving all my information on another drive and doing a complete erase and install. I took it to a local technician who fixed in 30mins, this is what he did:

    Boot to recovery and access via Terminal or you can boot to an OS installed on an external drive.

    Go to the root of the drive (/) and browse to directory /Library/Preferences

    Delete the file COM.APPLE.LOGINWINDOW.plist

    Just for good form, run the disk utility and repair the drive, then run disk permission repair.

    Restart.

    This in the end was the successful thing for me after much anguish. This has been my first mac software issue and was very disappointed in the lack of knowledge by Mac technicians. Although, now I am just happy to have a working mac again. Plus I got to learn a LOT of code in the process.

    Hopefully this might help someone else.
     
  15. darkgoob, May 8, 2012
    Last edited: May 8, 2012

    darkgoob macrumors 6502

    Joined:
    Oct 16, 2008
    #15
    What worked for me

    1) Upgraded to Lion from Snow Leopard on a RAID

    2) Could not login. Guest user disabled. Root user disabled. No other user accounts show up. F*(&

    3) Booted up from Lion install CD. Went into Terminal. Typed resetpassword, which opens up a separate window behind the Terminal window where you can reset the password of the root user on another drive. I reset the root user password for my locked out drive.

    4) At this time I also repaired permissions, and installed the 10.7.3 combo update from the terminal, on my RAID drive.

    Notes:
    Disk Utility in 10.7.0 cannot repair permissions on a RAID which is why I had to do it from terminal. This is the command to do it:
    diskutil repairpermissions /Volumes/MyDrive/
    diskutil also has other commands, google it or read the man page etc.

    Also, in case you're wondering how I got the 10.7.3 combo update .pkg file into the mix: I copied the 10.7.3 combo update .pkg file onto a USB stick from a different computer, then inserted it into this one, and ran the installer from terminal using this command:
    installer -pkg packageToInstall -target /Volumes/MyHD
    (ignore the errors at the beginning, about missing bundles, as they are meaningless!)

    5) Restarted and booted from the main drive again, logging in as root this time.

    6) Went to System Preferences and added a new user, typed in the short name as being the same name as my pre-existing account, and entered the same exact password (I understand this bit is important); then I said YES when it asked me if I wanted to base this user account on the pre-existing user folder!

    7) I had to go through all this same B.S. when I upgraded to Leopard or Snow Leopard, can't remember which, but I've been through this mess before, stupid Apple can't figure out how to make a damn system upgrade that "just works"... you would think that the user account part would BE IMPORTANT TO THEM...

    8) If at this time you find that a bunch of your folders that were not in your user directory (but which you have placed at the root level of your hard drive, or elsewhere like in Applications directory or in the Library) have now changed their "owner" to a weird number like 502, here's how to fix it:
    a) go to Terminal
    b) type this command for a file:
    sudo chown yourUserShortname:admin /Folder/path/To/filename.doc
    type this command for a folder whose contents you want to all be owned by your new user account:
    sudo chown -R yourUserShortname:admin /Folder/path/To/Folder/
    c) If that doesn't work because it says "Operation Not Permitted" then do this command:
    sudo chflags nouchg /Folder/path/To/filename.doc
    or
    sudo chflags -R nouchg /Folder/path/To/Folder/
    then repeat step (b) and now it will work!

    Hope this helps,

    - guy who keeps thinking that THE MORE AND MORE TIME GOES ON, THE LESS AND LESS MAC-LIKE THE MAC BECOMES, UNTIL IT HAS FINALLY STARTED TO BECOME A PC-LIKE HUSK CRUFTING ITS WAY THROUGH REALITY, DISGUISED IN A BEAUTIFUL MAC EXTERIOR
     

Share This Page