Installed Mavericks, started up computer, keyboard stuck in "mousekeys", can't log in

Discussion in 'Mac Basics and Help' started by Johnnystanley, Oct 23, 2013.

  1. Johnnystanley macrumors newbie

    Joined:
    Oct 23, 2013
    #1
    After Having installed Mavericks, my iMac starts up and when I get to the log in screen I cannot type as my keyboard (which is definitely connected) is controlling the mouse, however when I try turning this off by pressing the option key 5 times, nothing happens. I have tried restarting but it won't fix. Sometimes it lets me type for a couple of seconds before I hear the sound indicating mouse keys is on and then I can no longer type. If I had a short password I could type it in fast enough, but mine is too long for this.

    I have no idea how I would fix this this without being able to log in. :confused:
     
  2. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #2
    Is there any way you can connect a different keyboard at all? Do you know if you have the on screen keyboard enabled at login?
     
  3. Johnnystanley thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #3
    My keyboard itself isn't the issue, it's "mousekeys", and as far as I know there is no way to get an on screen keyboard in the log in screen
     
  4. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #4
    Yeah you can get an on screen keyboard at log in, but you have to enable it from the System Preferences, Users & Groups and Login Items, Show input menu in login window. It's likely you don't have it enabled right now and obviously unable to get that far to do so.
     

    Attached Files:

  5. Johnnystanley thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #5
    Unfortunately, no, it isn't enabled. What can I do then? Is there a way to disable mousekeys through something like single user mode? (which I have never used before)
     
  6. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #6
    I'm not sure. You're positive that pressing the Option key 5 times isn't working, right? You could try resetting the SMC, but I'm not optimistic that it will help. It won't hurt to try though.
     
  7. Johnnystanley thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #7
    Option key 5 times definitely doesn't work, and resetting SMC did nothing.
     
  8. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #8
    Maybe it's time to go into recovery mode and re-install.
     
  9. Johnnystanley thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #9
    Turns out a wired keyboard solves the problem. Thanks.
     
  10. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #10
    Glad you got it fixed.
     
  11. Johnnystanley thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #11
    It seems this is only a temporary fix as even with mousekeys completely disabled, if I return to the login screen it somehow magically activates. It's a very strange glitch that I never encountered before Mavericks, although looking online a handful of people have experienced it in the past.
     
  12. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #12
    It might be worth calling and/or reporting it to Apple.
     
  13. gabrielsermeno macrumors newbie

    Joined:
    Oct 26, 2013
    #13
    Having the same issues. Except I don't have a wired keyboard to even go and temp fix it at all. Any resolve on this issue would be awesome!
     
  14. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #14
    According to this Apple Doc, OS X Mavericks: Control the pointer using Mouse Keys, you can turn on Mouse Keys with the following key combination:

    You can also turn on Mouse Keys by pressing Option (⌥)-Command (⌘)-F5, then selecting the checkbox.​

    Maybe it works for turning it off as well.
     
  15. Jingol macrumors member

    Joined:
    Nov 22, 2012
    #15
    I had this issue

    I used a usb keyboard and could to log in. solves the problem
     

Share This Page