Installed new Digitzier/lcd, screen lights up but no action

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TwinofSian, Sep 10, 2012.

  1. TwinofSian macrumors member

    Joined:
    Oct 23, 2011
    #1
    I replaced my damaged iphone 4's digitizer and lcd.

    While I don't think I was able to get all the screws right, all the parts are securely in place, including the vibrator.

    I have not put the rear panel on.

    However, when I hold down the home + sleep button, the case lights up, and the screen lights up, but I get no apple logo.

    I turned the volume button on and plugged the iphone onto a charger connected to my Mac, and I heard the audio chirp, but no indication of any kind of iOS activity other than a lighter screen.
     
  2. thewall macrumors member

    thewall

    Joined:
    Oct 2, 2007
    Location:
    U.K
    #2
    The same happened to me and i found the ribbon that you had to thread through had not been connected properly, make sure you have thread the ribbon through undamaged and that the connector is fully seated
     
  3. TwinofSian thread starter macrumors member

    Joined:
    Oct 23, 2011
    #3
    I have a bad feeling the ribbon may actually be damaged.

    somehow it got pinched the first time when I secured the new lcd/digitier panel to the bay.

    I then unscrewed everything and re-attached the lcd panel to the iphone bay and made sure both ribbons were of equal length and able to reach their intended docking points.

    I am fairly certain the connectors are correctly attached, but the ribbon may damaged.
     

Share This Page